IBM Support

Build JAX-WS Web Services in SSFS 9.1 needs to use ANT 1.8.1

Technote (troubleshooting)


To expose JAX-WS Web Services, you must use Apache Ant 1.8.1


No response from web service call.


This issue is mainly caused by the package-info.class was not archived to the 'StercomXbeanXapi.jar' during the JAX-WS building in case use the Ant provided by Sterling Selling and Fulfillment Suite Foundation.


All application servers

Resolving the problem

Download Apache Ant 1.8.1 from the Apache Ant website ( and install using instructions provided by Ant.

Set ANT_HOME in your environment to point to the Ant 1.8.1 instance.
Set the USE_EXTERNAL_ANT property for your application server in sandbox.cfg. Valid values are true/false.

Steps to follow to use Ant 1.8.1 instance installed in step 1.
a. Add following property in sandbox.cfg file

b. Save the sandbox.cfg file, navigate to the bin directory of 9.1 install, and run the (.cmd for windows) command

Document information

More support for: Sterling Selling and Fulfillment Suite

Software version: 9.1

Operating system(s): Platform Independent

Reference #: 1617790

Modified date: 06 December 2014