Rational Developer for Power systems v8.5 cannot be installed into the same package group with Rational Developer for System z or Rational Developer for zEnterprise v8.5.1.

Technote (troubleshooting)


Problem(Abstract)

Rational Developer for System z or Rational Developer for zEnterprise v8.5.1 cannot be installed in the same package group as Rational Developer for Power Systems v8.5.

Symptom

When Rational Developer for Power Systems v8.5 is already installed in the system and if Rational Developer for System z or Rational Developer for zEnterprise v8.5.1 is selected for install in the same package group, Installation Manager will display an error message saying that the packages are not compatible:

"CRIMA1063E: Installing IBM® Rational® Developer for zEnterprise™ 8.5.1.0 is not allowed; it is not compatible with the other packages.
  In installation context "com.ibm.sdp.eclipse.ide":
    Software being installed: com.ibm.assembly.rdpower.main 2.0.7000.20121023_0109 (SE.1.com.ibm.assembly.rdpower.main 2.0.7000.20121023_0109)
    Software being installed: SE.1.com.ibm.assembly.rdz.enterprise.main 8.5.1000.rdz851O-I20121024_1012
    Only one of the following can be installed at once:
    SE.1.com.ibm.etools.cobol.application.model.feature 2.0.0.v20121023_0717
      SE.1.com.ibm.etools.cobol.application.model.feature 1.2.0.v20120926_0726
    Cannot satisfy dependency:
      From: com.ibm.assembly.rdpower.main 2.0.7000.20121023_0109 (SE.1.com.ibm.assembly.rdpower.main 2.0.7000.20121023_0109)
      To: SE.1.com.ibm.etools.cobol.application.model.feature [1.2.0,2.0.0)
    Cannot satisfy dependency:
      From: SE.1.com.ibm.assembly.rdz.enterprise.main 8.5.1000.rdz851O-I20121024_1012
      To: SE.1.com.ibm.etools.cobol.application.model.feature [2.0.0,3.0.0)"

Similar error message will be displayed if Rational Developer for Power Systems v8.5.1 is selected for installation in the same package group as Rational Developer for System z or Rational Developer for zEnterprise v8.5.



Environment

Windows, Linux

Resolving the problem

There are two options to get both products installed:

1.- Install Rational Developer for Power and Rational Developer for System z or Rational Developer for zEnterprise in different packages group.

2.- Rational Developer for Power Systems and Rational Developer for System z or Rational Developer for zEnterprise must be upgraded to version 8.5.1 in order for them to be installed in the same package group.

Rate this page:

(0 users)Average rating

Document information


More support for:

Rational Developer for Power Systems Software
Installation

Software version:

8.5, 8.5.1

Operating system(s):

Linux, Windows

Reference #:

1617725

Modified date:

2013-01-29

Translate my page

Machine Translation

Content navigation