Restrict Select Owner list in ticket applications

Technote (FAQ)


Question

How to restrict the Select Owner lookup to a specific list of users for the ticket applications such as Service Requests?

Cause

Complete list of users is displayed by the lookup

Answer

A requirement exists for a limited number of users to be displayed in the Owner lookup.

The list of users available in the Select Action -> Select Owner is dictated through a relationship in the TICKET object with a child object of PERSONGROUPVIEW.

The following steps are needed to achieve this requirement:
1. The required users need to be added to a specific Person Group in the Person Groups application, for example HELPDESK.
2. In order to locate the respective relationship in the environment, the TICKET object needs to be opened in Database Configuration.
3. The Relationships tab needs to be filtered by Child object for PERSONGROUPVIEW. The relationship should be present under the name PERSONS, with an out of the box clause of 1=1.
4. The PERSONS relationship needs to be changed as follows:

persongroup = :ownergroup or persongroup = 'HELPDESK'

where 'HELPDESK' is the person group created in step 1.

Once the relationship record is saved, the Owner person list will be limited to the users present in the HELPDESK Person Group.


Cross reference information
Segment Product Component Platform Version Edition
Systems and Asset Management IBM SmartCloud Control Desk Not Applicable AIX, HP-UX, Linux, Solaris, Windows 7.5 All Editions
Systems and Asset Management Tivoli Service Request Manager Not Applicable AIX, Linux, Solaris, Windows 2003 server, Windows 2008 server 7.1, 7.1.2, 7.2, 7.2.1, 7.5 All Editions
Systems and Asset Management Tivoli Asset Management for IT AIX, HP-UX, Linux, Solaris, Windows 7.1, 7.1.1, 7.1.2, 7.2, 7.2.1, 7.2.2, 7.5 All Editions
Systems and Asset Management Tivoli Change and Configuration Management Database Not Applicable AIX, Linux, Windows, Solaris, HP-UX, AIX 64bit 7.1, 7.1.1, 7.1.2, 7.2, 7.2.1, 7.2.2, 7.5 All Editions

Rate this page:

(0 users)Average rating

Document information


More support for:

IBM Maximo Asset Management
Person Groups

Software version:

7.0, 7.1, 7.1.1, 7.1.2, 7.2, 7.2.1, 7.5

Operating system(s):

AIX, HP-UX, Linux, Solaris, Windows

Software edition:

All Editions

Reference #:

1617562

Modified date:

2012-11-19

Translate my page

Machine Translation

Content navigation