Technote (troubleshooting)
Problem(Abstract)
When clicking on a Service Version in the Service Registry Detail Widget two error messages are displayed. The expanded error message text contains:
Method: _dataReportsFetchErrback - Message: An error occurred while retrieving the entity with the following bsrURI: <bsrURI>. Error message: <html> <head> <title>Error</title> <META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=utf-8"/> </head> <body> <div id="birt_errorPage" style="color:red"> <span id="error_icon" style="cursor:pointer" onclick="if (document.getElementById('error_detail').style.display == 'none') { document.getElementById('error_icon').innerHTML = '- '; document.getElementById('error_detail').style.display = 'block'; }else { document.getElementById('error_icon').innerHTML = '+ '; document.getElementById('error_detail').style.display = 'none'; }" > + </span> The report file : /<WAS_PROFILE_HOME>/installedApps/<CELL_NAME>/WSRRReportViewer.ear/WSRRReportViewer.war/ServiceRegistryBIRTReport
/render/ServiceVersionConsumers.rptdesign does not exist or contains& #32;errors.<br> <pre id="error_detail" style="display:none;" >
The important text being:
Message: An error occurred while retrieving the entity with the following bsrURI: <bsrURI>. Error message: The report file: <WAS_PROFILE_HOME>/installedApps/<CELL_NAME>/WSRRReportViewer.ear/WSRRReportViewer.war/ServiceRegistryBIRTReport/render/ServiceVersionConsumers.rptdesign does not exist or contains errors.
The second error message is the same as the first but references ServiceVersionProviders.rptdesign instead.
Cause
These errors occur because the active WSRR configuration profile does not contain two files which are necessary for this widget to function correctly: ServiceVersionConsumers.rptdesign and ServiceVersionProviders.rptdesign.
These files are new in V8.0 of the Governance Enablement Profile supplied with WSRR V8.0. Therefore if a profile has been migrated from a previous WSRR version these files will be missing and the errors will occur.
Resolving the problem
Edit the active WSRR configuration profile in the Configuration perspective of the WebUI as follows:
- Navigate to Active Profile > BIRT Report Design
- Load the two missing BIRT Report Design Configuration files:
- ServiceVersionConsumers.rptdesign
- ServiceVersionProviders.rptdesign
Product Alias/Synonym
WSRR
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