Skip to main content

Re-occurring error: RSV-SRV-0040 cannot open Crypto lib


Technote (troubleshooting)


Problem(Abstract)

After some period of normal running, the following error may occur when attempting to use the Cognos environment:

RSV-SRV-0040 An application error has occurred. Contact your Administrator.

Logfiles show the following complete message:

SecureErrorId: 2012-11-09-14:39:48.923-#118
Original Error: RSV-SRV-0040 An application error has occurred. Contact your Administrator.
CCLUnexpectedError:0:Fatal: cannot open Crypto lib

Regenerating the cryptographic keys resolves the issue, however after some time the issue returns.

Cause

Cognos folders were not added to the exclusion list of the anti-virus software monitoring the server.

Resolving the problem

Add the Cognos directory folder to the list of excluded files for the anti-virus software that is monitoring the server. If in the case of a distributed install, ensure that this is followed on all machines that house Cognos components in the environment.

Cross reference information
Segment Product Component Platform Version Edition
Business Analytics Cognos Business Intelligence Cognos Connection Windows 10.2, 10.1.1, 10.1, 8.4.1 All Editions

Rate this page:

(0 users)Average rating

Copyright and trademark information

IBM, the IBM logo and ibm.com are trademarks of International Business Machines Corp., registered in many jurisdictions worldwide. Other product and service names might be trademarks of IBM or other companies. A current list of IBM trademarks is available on the Web at "Copyright and trademark information" at www.ibm.com/legal/copytrade.shtml.

Rate this page:


(0 users)Average rating

Add comments

Document information

Cognos Business Intelligence


Software version:
8.4.1, 10.1, 10.1.1, 10.2


Operating system(s):
Windows


Reference #:
1617304


Modified date:
2013-01-22

Translate my page

Content navigation