IBM Support

Re-occurring error: RSV-SRV-0040 cannot open Crypto lib

Troubleshooting


Problem

After some period of normal running, the following error may occur when attempting to use the Cognos environment: RSV-SRV-0040 An application error has occurred. Contact your Administrator. Logfiles show the following complete message: SecureErrorId: 2012-11-09-14:39:48.923-#118 Original Error: RSV-SRV-0040 An application error has occurred. Contact your Administrator. CCLUnexpectedError:0:Fatal: cannot open Crypto lib Regenerating the cryptographic keys resolves the issue, however after some time the issue returns.

Cause

Cognos folders were not added to the exclusion list of the anti-virus software monitoring the server.

Resolving The Problem

Add the Cognos directory folder to the list of excluded files for the anti-virus software that is monitoring the server. If in the case of a distributed install, ensure that this is followed on all machines that house Cognos components in the environment.

[{"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Not Applicable","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2.1;10.2;10.1.1;10.1;8.4.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21617304