Worklight Direct Update Fails on Google Android when using secure session Cookies

Technote (troubleshooting)


Problem(Abstract)

Session information is improperly handled when some native features are invoked, such as the direct update, which leads to an unusable client application after a direct update is detected.

Cause

This issue only occurs when the session cookie is configured to be accessible exclusively from a secured protocol (HTTPS) by the application server.

Environment

This problem only affects Google Android clients.

Diagnosing the problem

This issue is due to a problem in Worklight native code in the Google Android environment

Resolving the problem

When supporting clients in an Android environment, you must disable the configuration option for the application server to use secure (HTTPS) session cookies.

Cross reference information
Segment Product Component Platform Version Edition
Mobile- Speech and Enterprise Access IBM Mobile Foundation Device Runtime Google Android 5.0, 5.0.0, 5.0.0.1, 5.0.0.2, 5.0.0.3 Consumer, Enterprise

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Document information


More support for:

IBM Worklight
Device Runtime

Software version:

5.0, 5.0.0.1, 5.0.0.3

Operating system(s):

Google Android

Software edition:

Consumer, Enterprise

Reference #:

1617207

Modified date:

2012-11-13

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