IBM Support

Using WebSphere Adapter for JDBC with Sybase database stored procedures

Troubleshooting


Problem

The processing of stored procedures fails when IBM WebSphere Adapter for JDBC tries to execute Sysbase stored procedures in chained mode.

Symptom

IBM WebSphere Adapter for JDBC generates the following error in the logs when trying to execute Sysbase stored procedures:

ResourceException thrown in J2CMethodBindingImpl.invoke() javax.resource.ResourceException: Stored procedure 'db.SP_ac_temp' may be run only in unchained transaction mode.

Cause

This error is thrown when Adapter tries to execute the stored procedures in chained mode, while Sysbase runs its stored procedures in unchained transaction mode by default.

Resolving The Problem

To work around this restriction, you must turn on the auto commit feature of the Adapter. This allows each transaction to be committed irrespective of any settings in the client's stored procedures.

To set the Auto commit Connection factory setting:
- Check the AutoCommit checkbox during Adapter configuration in the external service wizard.

To set the Auto commit on Embedded/Standalone Adapters:
- The setting logged in the Administration Console takes precedence over the setting logged in the Adapter.
- In the Administration Console, select Resources => Resource Adapters => Deployed Adapter.
- Set AutoCommit to true and save the changes.

[{"Product":{"code":"SSMKUK","label":"WebSphere Adapters Family"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Adapter for JDBC","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"7.5;7.0","Edition":"","Line of Business":{"code":"","label":""}}]

Document Information

Modified date:
22 June 2018

UID

swg21617168