Skip to main content

Unable to run any jobs from DataStage Designer or Director


Technote (troubleshooting)


Problem(Abstract)

Unable to run any jobs from DataStage Designer or Director. The job shows Compiled status in Director log.

Symptom

When an attempt to run a DataStage job from Designer is made, the run-time statics do not show any records processed. If the job is from Director, it shows "Compiled" status in the Director log. There is no indication that the job ever ran. There is no issue when compiling the job.


Cause

In the DataStage, DSEngine\bin (at 8.x) or Engine\bin (at 7.5.x) directory, there is an extra UVSH file with a size of 0 bytes in addition to the uvsh.exe.

Diagnosing the problem

Please check the following:

  1. Check the Windows Task Manager to see if the uvsh.exe process was started.
  2. Check the &PH& folder under the project directory for DSD.RUN_#### files started at the time the job was kicked off and look for a DSD.RUN_#### file 0 bytes in size.
  3. From the DataStage Administrator Command line window for the project, execute: PHANTOM SLEEP 1

    Look for the following error: Unable to create PHANTOM process
  4. Check the DSEngine\bin (at 8.x) or Engine\bin (at 7.5.x) directory for another file called uvsh in addition to the expected uvsh.exe.

Resolving the problem

This problem is caused when there is a UVSH file with 0 bytes under DSEngine\bin or Engine\bin directory in addition to the uvsh.exe file. There must only be one uvsh.exe under DSEngine\bin or Engine\bin directory. To resolve this issue, please remove the UVSH file.

Note: At 8.x the directory is called DSEngine and at 7.5.x it is called Engine.


Rate this page:

(0 users)Average rating

Copyright and trademark information

IBM, the IBM logo and ibm.com are trademarks of International Business Machines Corp., registered in many jurisdictions worldwide. Other product and service names might be trademarks of IBM or other companies. A current list of IBM trademarks is available on the Web at "Copyright and trademark information" at www.ibm.com/legal/copytrade.shtml.

Rate this page:


(0 users)Average rating

Add comments

Document information

InfoSphere DataStage


Software version:
7.5.2, 7.5.3, 8.0.1, 8.1, 8.5, 8.7


Operating system(s):
Windows


Reference #:
1617050


Modified date:
2012-11-15

Translate my page

Content navigation