IBM Support

IBM Content Collector Text Search Support installation fails due to NULL installation directory

Troubleshooting


Problem

IBM Content Collector Text Search Support installation fails due to NULL installation directory.

Symptom

  • When installing IBM Content Collector Text Search Support, the installer does not prompt the user for the installation directory.
  • Before it attempts to install, the summary shows the installation directory as null.
  • After installation completes, no files get created.

Cause

If the progress of the installation was interrupted abnormally before, some of the invalid values will be saved in the default registry file of Installanywhere. When the the installation was launched next time, the installation application will fetch those values from the registry file, and end-user does not have choice to set the configuration during the installation.

Environment

Installing IBM Content Collector Text Search Support

Resolving The Problem

  • Backup the registry file .com.zerog.registry.xml
  • For windows platform, C:\Program Files\Zero G Registry\.com.zerog.registry.xml
(hidden directory)
  • For UNIX-based platform, /var
  • Delete the registry file .com.zerog.registry.xml
  • Restart the installer.

[{"Product":{"code":"SSAE9L","label":"Content Collector"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"All Content Collector products","Platform":[{"code":"PF033","label":"Windows"}],"Version":"3.0;2.2","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21616851