IBM Support

Migrating to IBM Business Process Manager (BPM) results in log errors within the chart converter section of the migration log file

Troubleshooting


Problem

After you migrate to IBM Business Process Manager, the migration log contains errors in the chart converter section labeled as "Unknown" and "CWLLG3405I: The color '' is invalid."

Symptom

For example, the following items might exist in the migration log file within the chart converter section:

Oct 10, 2012 5:05:32 PM FINE: com.ibm.bpm.chart.converter.NetChartsConverterTool - value = List:[Tuple:[List:[String:Dial], List:[Unknown:SOLID], List:[Unknown:1], List:[Unknown:black], List:[Unknown:CENTER]]]

Oct 10, 2012 5:05:32 PM FINE: com.ibm.bpm.chart.converter.NetChartsConverterTool - value = List:[Tuple:[List:[String:Goal], List:[Unknown:], List:[Unknown:], List:[Unknown:]], Tuple:[List:[String:Budget], List:[Unknown:], List:[Unknown:], List:[Unknown:]], Tuple:[List:[String:Over], List:[Unknown:], List:[Unknown:], List:[Unknown:]], Tuple:[List:[String:Inner], List:[Unknown:], List:[Unknown:], List:[Unknown:]]]

Oct 22, 2012 2:56:34 PM INFO: com.ibm.bpm.chart.converter.ColorConverter - CWLLG3405I: The color '
none' is invalid. Processing continues, but the color may be displayed incorrectly. The error is '
java.lang.IllegalArgumentException: Bad color: none'.

Oct 22, 2012 2:56:34 PM INFO: com.ibm.bpm.chart.converter.ColorConverter - CWLLG3405I: The color '
lightred' is invalid. Processing continues, but the color may be displayed incorrectly. The error is '
java.lang.IllegalArgumentException: Bad color: lightred'.

Cause

The word "Unknown" refers to an unknown data type, which is detected by the parser. It means that the conversion tool did not detect a string data type. This behavior is the correct behavior for the conversion tool.

The "CWLLG3405I: The color <name> is invalid." message means that there is a reference to a color name that is no longer valid. Instead, the default color is used.

Conversion fidelity is not affected.

Resolving The Problem

The migration behavior is not affected by the existence of the previously described errors. If the migration log does not contain exceptions, the migration process completed correctly.

[{"Product":{"code":"SSFTN5","label":"IBM Business Process Manager Advanced"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Migration","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"},{"code":"PF035","label":"z\/OS"}],"Version":"8.5.0.1;8.5;8.0.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SSFTDH","label":"IBM Business Process Manager Standard"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Migration","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"","label":"Linux zSeries"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"8.5.0.1;8.5;8.0.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Product Synonym

BPM

Document Information

Modified date:
15 June 2018

UID

swg21616688