Running reports in the dashboard results in CRRDV0015E error

Technote (troubleshooting)


Problem(Abstract)

Attempts to view reports on the dashboard results in CRRDV0015E error with IBM Collaborative Lifecycle Management (CLM) products: IBM Rational Team Concert (RTC), IBM Rational Quality Manager (RQM) and IBM Rational Requirements Composer (RRC).

Symptom

Viewing reports in the project dashboard return the following error for each report.



    CRRDV0015E The report query results cannot be displayed. The server encountered an unexpected error that prevented it from retrieving the report query results. To find more details about this issue, open the JavaScript console of your browser by pressing F12, refresh the widget, and check the JavaScript console for any resulting errors

The following stack trace may be seen in the application log (jazz.log, ccm.log, qm.log or rm.log) for RTC, RQM or RRC:

    null ( 1 time(s) )
    detail : org.eclipse.birt.report.engine.api.EngineException
    at org.eclipse.birt.report.engine.executor.ExecutionContext.addException(ExecutionContext.java:1199)
    at org.eclipse.birt.report.engine.presentation.LocalizedContentVisitor.processExtendedContent(LocalizedContentVisitor.java:1046)
    .....
    Caused by: org.eclipse.birt.chart.exception.ChartException
    at org.eclipse.birt.chart.reportitem.ChartReportItemPresentationBase.onRowSets(ChartReportItemPresentationBase.java:875)
    at org.eclipse.birt.chart.reportitem.ChartReportItemPresentationProxy.onRowSets(ChartReportItemPresentationProxy.java:108)
    ...
    Caused by: java.lang.NullPointerException
    at org.mozilla.javascript.UintMap.rehashTable(UintMap.java:295)
    at org.mozilla.javascript.UintMap.ensureIndex(UintMap.java:360)


Cause

This issue is a defect with JIT compiler included with IBM WebSphere Application Server (WAS) 8.0.0.5 as well as 8.5.0.1

Note this issue can also be seen with earlier versions such as version 8.0.0.3 if all recommended JIT fixes are loaded.

APAR IV31201 has been opened to track this issue.

Note WebSphere Application Server 8.5 is not currently supported for use with RTC.
See the Application Servers section of the System Requirements for CLM 2012 documentation.

Environment

WebSphere Application Server 8.0.0.5, 8.5, 8.5.1 and Rational Team Concert 4.x and above

Resolving the problem

This issue has been resolved in WebSphere Application Server fix packs 8.0.0.6 and 8.5.0.2

If you are unable to update WAS at this time you can update to the JDK that includes this fix, plus all the latest security fixes by apply the i-fixes in this document.

If neither of these options are available to you then you will need to open a PMR with WebSphere Support to request a fix for your specific JDK level.

Leverage the Jazz Community
Jazz and Rational Team Concert have an active community that can provide you with additional resources. Browse and contribute to the User forums, contribute to the Team Blog and review the Team wiki.
Refer to technote 1319600 for details and links.

Cross reference information
Segment Product Component Platform Version Edition
Software Development Rational Quality Manager Web App Server 4.0, 4.0.0.1, 4.0.0.2, 4.0.1, 4.0.2
Software Development Rational Requirements Composer Web App Server 4.0, 4.0.0.1, 4.0.0.2, 4.0.1, 4.0.2

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

Rational Team Concert
Reports

Software version:

4.0, 4.0.0.1, 4.0.1, 4.0.2

Operating system(s):

AIX, Linux, Solaris, Windows

Reference #:

1616615

Modified date:

2013-01-04

Translate my page

Machine Translation

Content navigation