IBM Support

Getting alerts from Sterling Control Center when BP ran successfully on Sterling B2B Integrator

Technote (troubleshooting)


Problem(Abstract)

Getting alerts when a BP ran successfully on the Sterling B2B Integrator (SI) node. The BP runs successfully, but is run with full persistence and there are a few steps that have status "JMS Queued" and "BP queued" which apparently equate to WF_STATUS 11 and 12. These statuses are apparently being passed to Sterling Control Center (SCC) as "inError true", which in turn causes a return code 8, thus causing alerts to be issued (a rule is set up to alert if return code is not 0).

Symptom

SCC rule is set up to alert if return code is not 0


Cause

This has been identified as a product defect under APAR IC87312

Environment

Sterling Control Center monitoring SI

Diagnosing the problem

Review the Database Events report on SCC and Business Process History on SI

Resolving the problem

Added status codes 11 and 12 to a table in Sterling Control Center. These entries indicate to treat these conditions as successful.

Cross reference information
Segment Product Component Platform Version Edition
Commerce Sterling B2B Integrator AIX, HP-UX, IBM i, Linux, Solaris, Windows 5.2.4, 5.2.3, 5.2.2, 5.2.1, 5.2

Document information

More support for: IBM Control Center

Software version: 5.3

Operating system(s): AIX, HP-UX, Linux, Solaris, Windows

Reference #: 1616485

Modified date: 06 November 2012