Troubleshoot: "The digitally signed form data is not synchronized with case data" warning when a form is deployed in Case Manager

Technote (troubleshooting)


Problem

"The digitally signed form data is not synchronized with case data" warning when a form is deployed to IBM Case Manager

Cause

There is incorrect references to non-existing instances within the forms publicdata. Refer to Technote 2157312

Diagnosing the problem

1. Navigate through the publicdata and remove all redundant or duplicate items.

2. Look for all other items or references in the form that point to non-existing instances.

3. Remove all binds that have incorrect references in the constraint or correct them accordingly.

4. After making these changes, test the form in IBM Case Manager. If you are still seeing the warning message, remove the publicdata from the form and retest.

  • When the warning goes away after removing the publicdata from the form, you know there is still a problem with the publicdate.

5, Continue to incrementally go through each item within the publicdate to ensure all the references are correct.

6. Continue this process until the warning message is no longer seen.


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Document information


More support for:

IBM Forms Designer
Form design

Software version:

8.0, 8.0.0.1

Operating system(s):

Windows

Reference #:

1616462

Modified date:

2013-10-21

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