IBM Support

ClearCase not running on host (maybe Attache' client)

Troubleshooting


Problem

Attempts to run the 'cleartool hostinfo ' command in IBM Rational ClearCase results in the error "ClearCase not running on host (maybe Attache' client)".

Cause

Unknown

Diagnosing The Problem

Steps to diagnose:

  • Verify if the error is seen when the command is run on the server machine itself.
  • Verify and ensure there is no firewall enabled between the clients and the server machine.
  • Verify if DNS is being used and there are no issues.
  • Verify if the following, pointing to the server, works fine:
    • Ping using shortname, Fully Qualified Domain Name (FQDN) and IP address.
    • nslookup using shortname, FQDN and IP address.

Resolving The Problem

Steps to resolve:

  1. If the albd_server is actually running on the server machine, check that the "nscd" process is also running on it.
    A sporadic DNS problem, (if any, as suggested by the nslookup) would be mitigated if nscd is running.

  2. Verify if the server has multiple network interfaces. If so, it could be an alternate hostnames problem. Maybe the alternate_hostnames file was set up incorrectly on the server machine.

  3. Ensure that iptables and ip6tables is turned off at the server machine. If not, turn these off and verify the working.

  4. If these does not help, run an network trace from the client machine for the duration of the cleartool hostinfo <server_name> command.
    At the sametime, run and collect a tcpdump from the server machine.

[{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Cleartool","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"8.0;7.1.2;7.1.1;7.1.1.1;7.1;7.0.1.12","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21616450