Troubleshooting
Problem
An SQL error message shows when you open the Decision Center console, or the Installation Settings Wizard appears instead of opening existing projects after installating and migrating to a new version.
Symptom
One or more of the following behaviors may be observed, depending on your configuration, when connecting to Decision Center after migrating to a new version:
- The Decision Center home page may open but errors such as "ORA-00942: table or view does not exist" or "DB2 SQL Error: SQLCODE=-204, SQLSTATE=42704" show in the browser and server logs.
- Running the Decision Center diagnostic under the Configuration tab shows the message "Expected: JRules 8.0; Found: JRules 7.5" for the "Database schema version" test.
- The Decision Center console may fail to open with the message "Error: An unknown error occurred while trying to perform this operation: java.lang.RuntimeException: java.sql.SQLException: ORA-00904: "RTS_PROD"."BASELINE"."DOCUMENTATION": invalid identifier<br />".
- Connecting to the Decision Center console opens the Installation Settings Wizard in order to create a new schema even though Decision Center already contains rule or event projects.
The same could occur with Rule Team Server (RTS).
Cause
You may have omitted to migrate the Decision Center database after changing Decision Center to a new version, or that migration may have failed.
Diagnosing The Problem
If accessible, run the Decision Center diagnostic under the Configuration tab.
Resolving The Problem
If you are migrating from an earlier version, you will need to create the tables/views for the new version on an empty schema using the Decision Center Installation Settings Wizard and then migrate the previous data to the new schema.
If you have already done the migration, ensure that the migration was successful and that you are connecting the new schema by reviewing the Decision Center datasource definition. You may need to perform the migration again after clearing the new schema.
For more information on how to perform the migration, refer to following sections of the documentation, depending on which version you are migrating to:
- WebSphere Operational Decision Management V8.0 > Migrating
- WebSphere Operational Decision Management V7.5 > Migrating from JRules > Migrating from JRules V7 > Migrating the Rule Team Server database
- WebSphere ILOG JRules BRMS V7.1 > Migrating > Migrating from JRules 6.x > Migrating rule projects for rule authors > Rule Team Server database migration .
Note that regarding migration from V7.5 to V8.0, early versions of the V8.0 documentation are incomplete: you do need to migrate the database, using tasks gen-migration75-role & gen-migration75-script, similar to the tasks to migrate from V7.0. or V7.1.
You can refer to section WebSphere Operational Decision Management V8.0 > Migrating > Migrating from JRules > Migrating from JRules V7 > Migrating the Rule Team Server database > Running the Ant tasks for migration of the documentation for information on how to run these tasks since the steps are the same.
Also, these tasks may be missing from the build.xml (under <ODMInstallDir>\teamserver\bin), which would only contain the corresponding taskdef.
In such a case, you will need to add the following tasks to the file:
<target name="gen-migration75-role">
<fail message="Please define oldDatabaseSchemaName property" unless="oldDatabaseSchemaName"/>
<gen-migration75-role
username="${rtsAdmin.login}"
password="${rtsAdmin.password}"
serverURL="${server.url}"
datasourceName="${datasourceName}"
oldDatabaseSchemaName="${oldDatabaseSchemaName}"
outputFile="${outputFile}"/>
</target>
<target name="gen-migration75-script">
<fail message="Please define oldDatabaseSchemaName property" unless="oldDatabaseSchemaName"/>
<gen-migration75-script
username="${rtsAdmin.login}"
password="${rtsAdmin.password}"
serverURL="${server.url}"
datasourceName="${datasourceName}"
oldDatabaseSchemaName="${oldDatabaseSchemaName}"
outputFile="${outputFile}"/>
</target>
Find attached below a modified build.xml for V8.0.X to copy under <ODMInstallDir>\teamserver\bin in place of the existing one, if it is missing the above two tasks.
Note:
- If one of the issues described above does not occur after migrating to a new version and that the Decision Center instance was previously running properly, this could mean that the schema got corrupted (some tables or views got dropped). In such a case, restore your database to a previous version of the schema, taken when Decision Center was not showing the issue.
- If you are setting up a new Decision Center without any existing projects, make sure to have it connect to an empty schema: the Installation Settings Wizard will prompt you to create the tables and views as you connect to Decision Center. If you then have the generated script run from another tool, ensure it creates the tables in the schema Decision Center connects to and that the user has access to those artifacts (see Decision Center V8.0 > Configuring Decision Center > Configuring the Decision Center consoles on WebSphere Application Server > Configuring the Decision Center consoles on WebSphere Application Server > Step 1: Enforcing database user permissions).
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Document Information
Modified date:
10 August 2022
UID
swg21616403