OSA startup fails with DLC code 80103150

Technote (troubleshooting)


Problem(Abstract)

When attempting to start an OSA device, it fails with an EZZ4310I message reporting an 80103150 error code. This is especially likely for a new device, new processor, or the first time starting a new LPAR.

Symptom

EZZ4310I ERROR: CODE=80103150 REPORTED ON DEVICE GIGOSA1. DIAGNOSTIC CODE: 03


Cause

DLC code xxxx3150 when trying to activate an OSA is because of the PORTNAME on the TRLE (which matches the name on the DEVICE statement or the PORTNAME value on the INTERFACE statement) is not the same as had already been used by another stack (probably on another LPAR) sharing this same OSA port. All systems sharing an OSA port have to be configured with the same PORTNAME. If you do not think this is supposed to be sharing the port, then:

  • Check the TRLE's device numbers (and how the IOGEN maps these to CHPIDs).
  • If this is an OSA Express3, 4S, or 5S device with multiple ports per CHPID, then make sure the PORTNUM value on the TRLE is specified correctly.
Another consideration for OSA models with multiple ports per CHPID is that the PORTNAME needs to be different for each PORTNUM. Namely, if one (or the only) LPAR has a TRLE for the CHPID with PORTNUM=1 and the same PORTNAME as other LPARs have for PORTNUM0, then its activation will fail with this same code. Or worse, if this LPAR is the first one up, then all the other LPARs will fail trying to activate port 0.

Resolving the problem

Correct the TRLEs so that all LPARs on a CPC are referencing the OSA ports consistently.

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Document information


More support for:

z/OS Communications Server

Software version:

1.11, 1.12, 1.13, 2.1

Operating system(s):

z/OS

Reference #:

1616375

Modified date:

2012-12-26

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