Issue while creating a customer when YCDVerifyAddressWithAVSUE is enabled

Technote (troubleshooting)


Problem(Abstract)

Issue is faced while creating a customer from the Call Center Application specifically when YCDVerifyAddressWithAVSUE is enabled.

Symptom

Simulation Steps
1. When YCDVerifyAddressWithAVSUE is enabled, create a consumer with a
LoginID that already exists in the database.
2. Duplicate User Found popup is displayed.
3. Click OK and change the LoginID to a new value which has not been provided for any Consumer yet.
4. Now, click on Next button.

Observed Behavior
When Next button is clicked there is no change and the next screen is not displayed. No error gets logged in the debug logs as well.
When the YCDVerifyAddressWithAVSUE is disabled, the system behaves correctly.


Cause

The issue has been accepted as a defect and the fix is deferred to the next dev release.

Resolving the problem

Workaround available for this issue:

On click of Next button, in the postCommand of manageCustomer api, check if the output has YFS83_0009 error. If yes, then do the following:
YRCPlatformUI.enableAction("com.yantra.pca.ycd.rcp.tasks.customerConsumerEntry.actions.YCDConsumerCustomerEntryNextAction", true);

The action enabled as a work around for Create Consumer screen is com.yantra.pca.ycd.rcp
.tasks.customerConsumerEntry.actions.YCDConsumerCustomerEntryNextAction.
However, for Create Order: CustomerSelection -> Create Customer Screen,
'com.yantra.pca.ycd.rcp.tasks.customerConsumerEntry.actions.YCDConsumerC
ustomerEntryConfirmAction' should be enabled.

After enabling these actions, on click of Next button the consecutive screen would be displayed as expected.


Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

Sterling Order Management

Software version:

9.1

Operating system(s):

All

Reference #:

1616370

Modified date:

2013-03-31

Translate my page

Machine Translation

Content navigation