IBM Support

Update Rational Test Workbench components: prunsrv.exe error "status=5"

Troubleshooting


Problem

Attempts to update IBM Rational Test Workbench 8.0 components Rational Integration Tester Agent, Rational Integration Tester Platform Pack and Rational Test Control Panel result in "failed to delete ... dbgwrapper.dll".

Symptom

When you already installed the following Rational Test Workbench (RTW) 8.0 components as Windows services, attempts to upgrade or rollback the installation through the IBM Installation Manager result in failure.

  • Rational Integration Tester Agent (RIT Agent)
  • Rational Integration Tester Platform Pack (RIT PP)
  • Rational Test Control Panel (RTCP)


During the update process the uninstallation appears to succeed. However during the installation of the new versions, you see errors such as the following.

Error executing "C:\Program Files\IBM\RIT-Platform\httptcp\prunsrv.exe" operation (status=5)

Failed to delete C:\Program Files\ibm\RIT-Platform\jre\
bin\dbgwrapper.dll


The update has failed. You need to cancel the update.


REMARKS

  • This problem exists from version 8.0.0.0 of the components. The same workaround applies to upgrading to any of the 8.0.0.x fix packs, and to upgrading to 8.0.1 from any older release.

  • Upgrades from versions older than 8.0.1 to version 8.0.1 or newer will experience this problem.

  • The expectation is that upgrades from 8.0.1 to fix packs and newer releases will not encounter this problem.

  • The release date of version 8.0.1 was November 20, 2012.

Cause

During the update process, Installation Manager attempts to remove and reinstall the Windows services for these RTW components. This procedure cannot complete, because a system reboot is required to completely remove the old service entries before adding the new ones.

Environment

Windows 7, Windows XP, Windows Server 2003, Windows Server 2008

Diagnosing The Problem

Consult the IBM Installation Manager log files at the following path.

C:\ProgramData\IBM\Installation Manager\logs

Resolving The Problem

In short, the solution consists of the following steps.

  1. Stop the service before the uninstallation.
  2. Uninstall the existing version of the software.
  3. Reboot the computer.
  4. Install the new version.


Do not use the upgrade or rollback capability.


    1. Stop the applicable Windows services.

      IBM RIT Agent
      IBM RIT HTTP Proxy
      IBM RTCP

    2. Backup copies of any configuration file that you might have modified since installation.

    3. Additional steps for RTCP:

      Do not
      select the option to delete the workspace when uninstalling RTCP. Deleting the workspace will lose any saved work including published stubs and scheduled tasks.





      Ensure you do not select the Delete Workspace check-box.
      If you are using a non-default location for the workspace you will need to know this location when installing the new version. To find out the location of your workspace open the container.server.properties file and note the setting of workingDirectory.

      A typical location for this file is:

      C:\Program Files\IBM\RationalTestControlPanel\webapps\
      RTCP\WEB-INF\classes\container.server.properties

      A typical entry is:

      workingDirectory=C\:\\RTW\\RTCP-Workspace


    4. Uninstall the component completely through IBM Installation Manager.

    5. Ensure that the installation folders are empty.

      Example folder locations are as follows:


      C:\Program Files\IBM\RIT-Agent
      C:\Program Files\IBM\RIT-Platform
      C:\Program Files\IBM\RationalTestControlPanel


      If you configured the RTCP workspace to be within the installation directory (not recommended) you must move this to a temporary location. Then you can reinstated the workspace after reinstallation

    6. Reboot the computer

    7. Install the new version of the component.

      Click the Check for Other Versions, Fixes and Extensions button and click the Show all versions check-box and select installation of your required version.

      Additional step for RTCP:
      Enter the Workspace Path value found in step 3.



      This ensures that the new version of RTCP will use your existing workspace with all published stubs and scheduled jobs.

    8. Edit the configuration files to add any previous settings back in by comparing with the saved versions.
      Do not move saved config files back into the new installations as you may lose new settings that have been added in the updated releases.

    9. Move the backup files into place. Then re-start the IBM RTCP service, if the RTCP workspace location is within the installation directory,

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Document Information

Modified date:
29 September 2018

UID

swg21616116