Importing WebSphere Application Server 7 results in NullPointerException error

Technote (troubleshooting)


Problem(Abstract)

Attempts to import IBM WebSphere Application Server version 7 in IBM Installation Manager results in internal error on the summary panel of the install wizard during "Finishing...".

Symptom

The log file contains an error similar to the following entry:

<entry num='61' time='1345681411955' elapsed='06:43.53' level='ERROR' thread='Worker-2'>
<logger>com.ibm.cic.common.logging.LogManager</logger>
<class>org.eclipse.core.internal.jobs.JobManager</class>
<method>endJob</method>
<message>An internal error occurred during: "Finishing...".
java.lang.NullPointerException
</message>
<exception>
java.lang.NullPointerException
<stack>com.ibm.cic.common.core.extensions.ExtensionIdFilter.exclude(ExtensionIdFilter.java:57)</stack>
<stack>com.ibm.cic.common.core.extensions.ExtensiongetConfigurationElements(ExtensionManager.java:88)</stack>
<stack>com.ibm.cic.common.core.extensions.ExtensionManager.getConfigurationElements(ExtensionManager.java:59)</stack>
<stack>com.ibm.cic.agent.core.LocationCheckManager.initializeLocationChecks(LocationCheckManager.java:113)</stack>
<stack>com.ibm.cic.agent.core.LocationCheckManager.initializeAndPerform(LocationCheckManager.java:229)</stack>
<stack>com.ibm.cic.agent.internal.core.Director.install(Director.java:588)</stack>
<stack>com.ibm.cic.agent.core.Agent.install(Agent.java:1632)</stack>
<stack>com.ibm.ws.sync.core.SyncEngine.PerformSynchronization(SyncEngine.java:149)</stack>
<stack>com.ibm.ws.sync.ui.extensions.ImportWASWizard$1.run(ImportWASWizard.java:196)</stack>
<stack>com.ibm.cic.common.ui.internal.parts.ProgressPart$ProgressJob.run(ProgressPart.java:104)</stack>
<stack>org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)</stack>
</exception>
</entry>

Cause

This issue can occur when bundles are not released after performing an installation, update, modification, roll back, or an uninstall.

Resolving the problem

Procedure:

  1. Restart Installation Manager

  2. View the installed packages to determine if WebSphere Application Server 7 was imported

  3. If the server was not imported, try importing the server again.

    Note: Do not perform any other operation in Installation Manager before you start the import.

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Document information


More support for:

IBM Installation Manager
General information

Software version:

1.3.1, 1.3.2, 1.3.3, 1.3.4, 1.3.4.1, 1.4, 1.4.1, 1.4.2, 1.4.3, 1.4.4, 1.5, 1.5.0.1, 1.5.1, 1.5.2, 1.5.3, 1.6, 1.6.1

Operating system(s):

AIX, HP-UX, Linux, Solaris, Windows

Reference #:

1616003

Modified date:

2012-12-11

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