IBM Support

Error DPR-ERR-2077 Failed to forward the request because the associated external process with PID is unavailable

Troubleshooting


Problem

List report fails to run and gives error "DPR-ERR-2077 Failed to forward the request because the associated external process with PID is unavailable"

Symptom

Following is the detailed error message :

Cause

The query associated with list object had the property 'Processing' set to "Database only", however the query had calculated data items which needs local processing, hence causing the error.

Environment

Windows, Unix

Resolving The Problem

Steps to resolve the error:

1. Open the report In Report Studio.
2. Click on 'Query Explorer' and then select the query associated with list report.
3. Set the property 'Processing' to Default or Limited Local
4. 'Use Local Cache' as Default.
5. Save the report.
The report should now run successfully.

[{"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Report Studio","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"},{"code":"PF016","label":"Linux"}],"Version":"10.2.2;10.2.1;10.2;10.1.1;10.1;8.4.1","Edition":"All Editions","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21615939