Getting error DPR-ERR-2077 Failed to forward the request because the associated external process with PID is unavailable

Technote (troubleshooting)


Problem(Abstract)

While running a report we end up getting error DPR-ERR-2077 Failed to forward the request because the associated external process with PID is unavailable. This report contains a list object.

Symptom

Following error is received while running a report which has a list object

DPR-ERR-2077 Failed to forward the request because the associated external process with PID is unavailable, either because the process is shutting down, or this was an absolute affinity request and the requested process does not exist anymore. For more information enable the dispatcher and external process detailed logs, and reproduce the conditions that caused the error.


Cause

The query associated with list object had the property 'Processing' set to database only, however the query had calculated data items which needs local processing, hence causing the error.


Environment

Windows, Unix

Resolving the problem

Steps to resolve the error:


1. Open the report In Report Studio.
2. Click on 'Query Explorer' and then select the query associated with list report.
3. Set the property 'Processing' to Default or Limited Local
4. 'Use Local Cache' as Default.
5. Save the report.
6. Now execute the report it should successfully.

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Document information


More support for:

Cognos Business Intelligence
Report Studio

Software version:

8.4.1, 10.1, 10.1.1, 10.2, 10.2.1

Operating system(s):

AIX, HP-UX, Linux, Solaris, Windows

Software edition:

All Editions

Reference #:

1615939

Modified date:

2013-12-23

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