Duplicate row failure message in objectserver log for TBSM

Technote (troubleshooting)


Problem(Abstract)

A message similar to the following seen in the objectserver log.

Attempt to insert duplicate row on line 1 of statement 'INSERT INTO alerts.service_deps (Service, EventKey, KeyField)

Symptom

Error message in objectserver log.


Cause

When TBSM inserts a row into the alerts.service_deps table, it does not check if the row already exists. So, if a row does exist this error is logged. This can happen in certain circumstances, such as in objectserver has fail-over or fail-back.

TBSM does not check if the row exists before trying to insert, it is more efficient to allow the failure to happen.

TBSM will ignore and not log the failure, but the objectserver will log it.


Resolving the problem

None. The error can be ignored.

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Document information


More support for:

Tivoli Business Service Manager

Software version:

4.2.1, 6.1

Operating system(s):

AIX, Linux, Linux zSeries, Solaris, Windows

Reference #:

1615586

Modified date:

2014-09-02

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