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"System.Exception: Security Error 2" when reschedule job for import external data from staging table

Troubleshooting


Problem

User clicks "Rransfer - External data - Import from staging table". User tries to reschedule a job. User receives an error. Problems does not affect all users - it only affects users who have limitations on a menu group.

Symptom

Standard Error
Error Detail:
Source: ControllerProxyClient
Description: System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> System.Exception: Security Error 2 at
Cognos.Controller.Proxy.SoapExtension.ServerExtension.ProcessMessage(SoapMessage message) at ...

Cause

Code production problem (APAR PM76021) in early versions of Controller 10.1.1.

Resolving The Problem

Fix:
Upgrade to Controller 10.1.2155 or later.

Workaround:
Use either of the following methods:

  • Method #1 - Remove the restrictions from the Users in Rights.
  • Method #2 - Modify the "WebServiceAccessControlList.acl" file on the Controller application server.

Steps for Method #2
  1. Logon to the Controller application server
  2. Open the "ControllerProxyServer" folder. TIP: By default this is located here: C:\Program Files (x86)\ibm\cognos\c10\ControllerProxyServer
  3. Open the file "WebServiceAccessControlList.acl" inside NOTEPAD.EXE
  4. Locate the following two lines, and modify them (to add the number 60338) so that they now look as follows:

clsBatchT_DeleteBatchJob =60313,60338 ;R
clsBatchT_RescheduleSpecificBatchJob =60313,60338 ;R

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.1.1","Edition":"All Editions","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21615568