Troubleshooting
Problem
User clicks "Rransfer - External data - Import from staging table". User tries to reschedule a job. User receives an error. Problems does not affect all users - it only affects users who have limitations on a menu group.
Symptom
Standard Error
Error Detail:
Source: ControllerProxyClient
Description: System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> System.Exception: Security Error 2 at
Cognos.Controller.Proxy.SoapExtension.ServerExtension.ProcessMessage(SoapMessage message) at ...
Cause
Code production problem (APAR PM76021) in early versions of Controller 10.1.1.
Resolving The Problem
Fix:
Upgrade to Controller 10.1.2155 or later.
Workaround:
Use either of the following methods:
- Method #1 - Remove the restrictions from the Users in Rights.
- Method #2 - Modify the "WebServiceAccessControlList.acl" file on the Controller application server.
Steps for Method #2
- Logon to the Controller application server
- Open the "ControllerProxyServer" folder. TIP: By default this is located here: C:\Program Files (x86)\ibm\cognos\c10\ControllerProxyServer
- Open the file "WebServiceAccessControlList.acl" inside NOTEPAD.EXE
- Locate the following two lines, and modify them (to add the number 60338) so that they now look as follows:
clsBatchT_DeleteBatchJob =60313,60338 ;R
clsBatchT_RescheduleSpecificBatchJob =60313,60338 ;R
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Document Information
Modified date:
15 June 2018
UID
swg21615568