Transactions created before an upgrade are not visible in "View Requests"

Technote (troubleshooting)


Problem(Abstract)

After a ISIM version upgrade, transactions created before the upgrade cannot be seen in "View Requests" .. only transactions created after the upgrade can be seen.

Cause

Database queries are generated to tables in the ITIMDB database to perform view requests. The first query is always for the PROCESS table and includes table column 'TENANT' as part of the query arguments. The "case" of the data in the TENANT column is derived from properties in enRole.properties. Since queries to the database are case-sensitive, any change of

case in those properties in the upgraded system will generate queries which will not find transactions that were created prior to the upgrade.

Diagnosing the problem

Examine the following enRole.properties properties in the before-upgrade system:


enrole.defaulttenant.id=Acme
enrole.organization.name=Acme Jet Roller Skates
enrole.ldapserver.root=dc=com

Examine the same properties in the after-upgrade system:

enrole.defaulttenant.id=acme
enrole.organization.name=acme Jet Roller Skates
enrole.ldapserver.root=dc=COM

The "case" of each of the property values must match exactly between the before-upgrade
and afer-upgrade systems. This mismatch typically occurs when the properties
files are manually configured as part of a non-standard upgrade procedure.


A example of a before-upgrade query to the PROCESS table, which yields results, might be as follows:

SELECT * FROM itimuser.PROCESS WHERE ((TENANT = 'ou=Acme,dc=com')
AND (PARENT_ID = 0)) AND ((SUBMITTED > '2008-08-14 04:00:00:000 GMT' AND SUBMITTED < '2008-08-15 03:59:59:999 GMT')
OR (SUBMITTED IS NULL)) ORDER BY SUBMITTED DESC, ID DESC FETCH FIRST 1001 ROWS ONLY


An example of an after-upgrade query with the case mismatch condition and which does NOT yield results, might be:

SELECT * FROM itimuser.PROCESS WHERE ((TENANT = 'ou=acme,dc=COM')
AND (PARENT_ID = 0)) AND ((SUBMITTED > '2008-08-14 04:00:00:000 GMT' AND SUBMITTED < '2008-08-15 03:59:59:999 GMT')
OR (SUBMITTED IS NULL)) ORDER BY SUBMITTED DESC, ID DESC FETCH FIRST 1001 ROWS ONLY


Resolving the problem

Ensure that the case of enrole.defaulttenant.id and/or enrole.ldapserver.root in enRole.properties in an after-upgrade system matches the same properties as in the before-upgrade system. Restart ISIM to effect the change.

Note: Transactions created while the case mismatch condition is present will not be visible once the necessary case corrections are made.

Product Alias/Synonym

itim isim tim sim

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Document information


More support for:

IBM Security Identity Manager
Server

Software version:

All Versions

Operating system(s):

AIX, Linux, Solaris, Windows

Reference #:

1615483

Modified date:

2014-09-23

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