IBM Support

ANR0188E ... Database manager license not found on Windows environment

Troubleshooting


Problem

After an install or upgrade of the Tivoli Storage Manager Server V6.x or higher on Windows, the server may fail to start with the following error : ANR0188E Fail to start the database manager. Database manager license not found

Cause

DB2 License has expired.

Diagnosing The Problem

Starting the Tivoli Storage Manager server will show the following messages :

ANR0990I Server restart-recovery in progress.
ANR0188E Fail to start the database manager. Database manager license not found
ANR0172I rdbdb.c(1619): Error encountered performing action InstanceStop.
ANR0162W Supplemental database diagnostic information: -1032:SQLSTATE 57019: The statement was not successful, because of a problem with a resource.
:-1032 (SQL1032N No start database manager command was issued. SQLSTATE=57019).

Resolving The Problem

Follow the steps below to resolve the problem.

1: First, verify that the above issue is exactly related to DB2 license file being expired.

> Logon to the Windows machine using a Tivoli Storage Manager Server instance userid.
> Start a Windows Command Prompt and run the following command which will start another Windows Command Prompt with the DB2 environment initialized (DB2CLP) :
> From the DB2CLP window, enter the following command "db2licm -l" and you should see info similar to the following:

Product name: "DB2 Enterprise Server Edition"
Expiry date: "Expired"
Product identifier: "db2ese"
Version information: "9.5"

NOTE: The DB2 Version will vary depending on the DB2 version included with the Tivoli Storage Manager server package.

2: The DB2 license file( db2ese.lic ) is shipped with our Tivoli Storage Manager and Spectrum Protect server packages and can be found in the following locations depending on where you extracted the package :

Versions 6.X :

?:\extract_dir\COI\PackageSteps\DB2_9.5\FILES\ese\db2\license\db2ese.lic
NOTE: The DB2 Version will vary depending on the DB2 version included with the Tivoli Storage Manager server package.

Versions 7.X :

The db2ese.lic is within a compressed XML file called "com.tivoli.dsm.server.db2.win.X64_10.5.500.111". The filename will depend on the exact version of DB2 shipped, but is located in :

?:\extract_dir\repository\native

The license file is within the ESE\db2\license folder within the compressed xml file.

3: Now, the DB2 license can be registered again with the following command from the directory where the license file is located and the corresponding messages will be displayed.


db2licm -a db2ese.lic
LIC1402I License added successfully.


4: Verify that the license has been successfully applied via the "db2licm -l" command.


Product name: "DB2 Enterprise Server Edition"
License type: "Restricted"
Expiry date: "Permanent"
Product identifier: "db2ese"
Version information: "9.5"

NOTE: The DB2 Version will vary depending on the DB2 version included with the Tivoli Storage Manager server package.

5: Start your Tivoli Storage Manager Server instance normally..

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Document Information

Modified date:
17 June 2018

UID

swg21615145