Skip to main content

The unit test environment (UTE) server not start properly after installing the Lotus WebForm Server


Technote (troubleshooting)


Problem(Abstract)

Why does the unit test environment (UTE) server not start properly after I have installed the Lotus WebForm Server, which is packaged with WebSphere Integration Developer and WebSphere Dynamic Process Edition, into the UTE server profile in WebSphere Integration Developer and WebSphere Dynamic Process Edition?

Cause

The WebSphere Process Server UTE server profile uses embedded Derby for the common WebSphere Process Server database so that it supports only one connection at a given time. However, if Lotus WebForm Server is installed into the same profile as the WebSphere Process Server UTE server, both servers for Lotus WebForm Server and WebSphere Process Server must connect to the WebSphere Process Server database while running, which means that WebSphere Process Server cannot function properly if Lotus WebForm Server is already connected to the database.

Resolving the problem

Two solutions are available for this issue:

You can create another profile (a WebSphere Application Server profile is sufficient) and install Lotus WebForm Server into that profile.

Alternatively, you can reverse the order in which the two servers are started:

  1. Open the Windows Control Panel and select Administrative Tools > Services.
  2. Stop WebSphere Application Server V7.0 for Lotus WebForm Server if it is started, and change its startup type from automatic to manual.
  3. Open WebSphere Integration Developer, and start the test server in WebSphere Process Server.
  4. Verify the log and console to ensure that the server started successfully without any exceptions.
  5. In Services, start the WebSphere Application Server instance for Lotus WebForm Server.

Note: You will see exceptions in the system log for Lotus WebForm Server for failed connections to the database for WebSphere Process Server. However, Lotus WebForm Server functions properly because it does not depend on functions from the underlying profile for WebSphere Process Server.

Cross reference information
Segment Product Component Platform Version Edition
Business Integration WebSphere Dynamic Process Edition Installation AIX, HP-UX, Linux, Solaris, Windows 7.0.1.1, 7.0.1, 7.0.0.3, 7.0.0.2, 7.0.0.1, 7.0, 6.2

Rate this page:

(0 users)Average rating

Copyright and trademark information

IBM, the IBM logo and ibm.com are trademarks of International Business Machines Corp., registered in many jurisdictions worldwide. Other product and service names might be trademarks of IBM or other companies. A current list of IBM trademarks is available on the Web at "Copyright and trademark information" at www.ibm.com/legal/copytrade.shtml.

Rate this page:


(0 users)Average rating

Add comments

Document information

WebSphere Integration Developer

Test and deployment tools


Software version:
6.2, 6.2.0.1, 6.2.0.2, 6.2.0.3, 7.0, 7.0.0.1, 7.0.0.2, 7.0.0.3, 7.0.0.4, 7.0.0.5


Operating system(s):
Linux, Windows


Reference #:
1614705


Modified date:
2012-10-29

Translate my page

Content navigation