Multi-homed server does not report expected IP

Technote (FAQ)


Question

Why is your multi-homed server not reporting the expected IP?

Cause

Server Protection for Windows chooses the first IP in the Windows binding order to use the reported Agent IP.

Answer

You can manually set the Agent IP value by adding a tuning parameter to the sigs.ini file on the agent itself:

agent.ip = [ip_address]

For instance, on a system that has multiple adapters listening on 192.168.1.2 and 172.16.10.100, you could fix the agent.ip value to one or the other by adding either

agent.ip = 192.168.1.2

or

agent.ip = 172.16.10.100

Notes:

There is not a way to modify sigs.ini from SiteProtector; as such this change must be made manually on each agent.

If your sigs.ini is encrypted, you will need to disable 'Encrypt configuration files' in the Administration policy under Agent Protection, push this policy to the agent, and modify the plain-text policy while the sensor is stopped. 'Encrypt configuration files' can be re-enabled afterward and the changes will be retained in the encrypted version of the file

Currently there is no way to configure the agent to use a DHCP address assigned to a given interface.


If the above information does not resolve your issue, please contact IBM Security Systems Customer Support.

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Document information


More support for:

IBM Security Host Protection

Software version:

2.2.2

Operating system(s):

Windows

Reference #:

1614038

Modified date:

2013-02-20

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