WBI-FN V3.1.1 Java Stored Procedures fail to run with JBDC 3.63 or JDBC 4.13

Flash (Alert)


This document applies only to the following language version(s):

US English

Abstract

WBI-FN Stored procedures fail when JDBC version 3.63 or 4.13 is used. DNI_SYSADM commands show SQLCODE = -4302 and java.lang.NullPointerException SQLSTATE 38000, DNI_SECADM commands show "Exception 'DECLARE usrCursor; Exc: null'"

Content

For DB2 V8, V9 and V10 with JCC 3.63 or JCC 4.13
WBI-FN Stored Procedure fail when dnicli calls the stored procedures.

For DB2 V8, the problem was introduced with UK76375 for JCC 3.63
For DB2 V9, the problem was introduced with UK76376 for JCC 3.63
and with UK76381 for JCC 4.13
For DB2 V10, the problem was introduced with UK76374 for JCC 3.63
and with UK76380 for JCC 4.13.

To prevent this problem, please don't apply the above mentioned PTFs.
If you're already experiencing the problem, please apply the following PTFs:

DB2 Version 8:
- PTF UK78527 for JCC 3.63 driver APAR PM58951

DB2 Version 9:
- PTF UK78528 for JCC 3.63 driver APAR PM58951
- PTF UK78530 for JCC 4.13 driver APAR PM58952

DB2 Version 10:
- PTF UK78526 for JCC 3.63 driver APAR PM58951
- PTF UK78529 for JCC 4.13 driver APAR PM58952


These PTF are available for download or can be ordered by opening a PMR for DB2.

Product Alias/Synonym

WBI-FN V3.1.1

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

WebSphere Business Integration for Financial Networks
Documentation

Software version:

3.1.1

Operating system(s):

z/OS

Reference #:

1613759

Modified date:

2012-10-16

Translate my page

Machine Translation

Content navigation