An issue occurs with the Microsoft Distributed Transaction Coordinator (MS DTC) when using IBM Business Process Manager (BPM) JDBC XA transactions with an Microsoft SQL Server 2008 on a Windows Server 2008 cluster

Technote (troubleshooting)


Problem(Abstract)

When running IBM Business Process Manager JDBC XA transactions against Microsoft SQL Server 2008 on a Windows Server 2008 cluster, an issue occurs with the Microsoft Distributed Transaction Coordinator (MS DTC).

Symptom

You might see an error similar to the following text in the SystemOut.log file:

WTRN0078E: An attempt by the transaction manager to call start on a transactional resource has resulted in an error. The error code was XAER_RMERR. The exception stack trace follows:
javax.transaction.xa.XAException: com.microsoft.sqlserver.jdbc.SQLServerException: Failed to enlist. Error: "Import of Microsoft Distributed Transaction Coordinator (MS DTC) transaction failed: 0x8004d00e(XACT_E_NOTRANSACTION)."


Cause

This problem is related to Microsoft SQL Server databases on Microsoft Windows Server 2008 because previous versions of the Windows Server Edition had only one DTC Service in a cluster. With Windows Server 2008, each member can have its own DTC Service. This difference is either the application requesting a transaction has to specify which DTC to use or you have to create a mapping, which is the case for all Java Database Connectivity (JDBC)-based transactions.


Resolving the problem

Follow the instructions for the Microsoft operating system and the database product. Refer to the following documents for the Microsoft DTC configuration:

Cross reference information
Segment Product Component Platform Version Edition
Business Integration IBM Business Process Manager Express Web Services Linux, Linux zSeries, Windows 8.0, 7.5.1.2, 7.5.1.1, 7.5.1, 7.5.0.1, 7.5
Business Integration IBM Business Process Manager Standard Web Services AIX, Linux, Linux zSeries, Solaris, Windows 8.0, 7.5.1.2, 7.5.1.1, 7.5.1, 7.5.0.1, 7.5

Product Alias/Synonym

BPM

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

IBM Business Process Manager Advanced
Web Services

Software version:

7.5, 7.5.0.1, 7.5.1, 7.5.1.1, 7.5.1.2, 8.0

Operating system(s):

AIX, Linux, Linux zSeries, Solaris, Windows, z/OS

Reference #:

1613696

Modified date:

2013-09-05

Translate my page

Machine Translation

Content navigation