Quickr 8.5 installation fails with NIFException while installing WebSphere Application Server

Technote (troubleshooting)


Problem

Quickr 8.5 install fails during the installation of WebSphere Application Server with NIFException.

Symptom

In wpinstalllog.txt, the following message is found:

=============================
(Oct 4, 2012 10:31:36 AM), Quickr.install,
com.ibm.wps.install.ExternalCommandAction, msg2, Completed install
step: Installing WebSphere Application Server. This step will take
several minutes.
(Oct 4, 2012 10:31:36 AM), Quickr.install,
com.ibm.wps.install.ScanFileAction, msg1,
fileName=C:\IBM\WebSphere\AppServer/logs/install/log.txt
(Oct 4, 2012 10:31:36 AM), Quickr.install,
com.ibm.wps.install.ScanFileAction, msg1, Search string not found

=============================

In the corresponding log.txt, the following exception can be seen:

=============================
(Oct 4, 2012 10:31:34 AM), Process,
com.ibm.ws.install.ni.ismp.actions.InstallNIFMaintenance, err,
C:\IBM\WebSphere\AppServer\properties\version\nif\backup\NIFStack.xml (The
requested operation cannot be performed on a file with a user-mapped
section open.)
(Oct 4, 2012 10:31:34 AM), Process,
com.ibm.ws.install.ni.ismp.actions.InstallNIFMaintenance, err,
C:\IBM\WebSphere\AppServer\properties\version\nif\backup\NIFStack.xml (The
requested operation cannot be performed on a file with a user-mapped
section open.)
(Oct 4, 2012 10:31:34 AM), Process,
com.ibm.ws.install.ni.ismp.actions.InstallNIFMaintenance, err,
com.ibm.ws.install.ni.framework.NIFException:
C:\IBM\WebSphere\AppServer\properties\version\nif\backup\NIFStack.xml (The
requested operation cannot be performed on a file with a user-mapped
section open.)
at
com.ibm.ws.install.ni.ismp.utils.ISMPLogUtils.logException(ISMPLogUtils.
java:46)
at
com.ibm.ws.install.ni.ismp.actions.InstallNIFMaintenance.execute(Install
NIFMaintenance.java:105)
at
com.installshield.wizard.RunnableWizardBeanContext.run(RunnableWizardBea
nContext.java:20)

(Oct 4, 2012 10:31:34 AM), Process,
com.ibm.ws.install.ni.ismp.actions.SettleNIFRegistryAction, msg1,
Current install/uninstall process failed.
(Oct 4, 2012 10:31:34 AM), Process,
com.ibm.ws.install.ni.ismp.actions.SetExitCodeAction, msg1, CWUPI0000I:
EXITCODE=1
(Oct 4, 2012 10:31:34 AM), Process,
com.ibm.ws.install.ni.ismp.actions.ISMPLogSuccessMessageAction, msg1,
INSTCONFFAILED

=============================

Cause

The message "a user-mapped section open" typically means a running process is using that file and the installer is unable to proceed. On Windows, this is most commonly caused by an Anti-virus

program or Desktop search software.


Diagnosing the problem

Check the wpinstalllog.txt and log.txt for the above error messages. The files can be found here:


<PortalServer root>/log/wpinstalllog.txt
<AppServer root>/logs/install/logt.txt


Resolving the problem

1. Manually uninstall the existing environment.


2. Shut down any file indexing services you may have running. Be sure to shut down all of them. This includes any antivirus software (such as Norton Antivirus) or desktop search software (like Google Desktop).

3. Re-attempt the installation

4. After the install completes, re-enable whatever Windows services were disabled.



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Document information


More support for:

Lotus Quickr for WebSphere Portal
Installation

Software version:

8.5

Operating system(s):

Windows

Reference #:

1613638

Modified date:

2012-10-26

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