Reset Test Environment command in Case Manager Builder can fail in a cluster environment.

Technote (troubleshooting)


Problem(Abstract)

Why does Case Manager Builder's Reset Test Environment feature fail when run in a cluster environment?

Symptom

In a cluster environment you may experience exceptions when running Case Manager Builder's Reset Test Environment feature. These exceptions can include:
FNRPA0071E : Data cannot be retrieved from the connection definition because the following error occurred: The security ID {...} cannot be found in the security descriptor table ..


Cause

Due to timing issues with cluster node cache synchronization, when the target object store's tables are automatically dropped and recreated, this error condition can occur.

Environment

IBM Case Manager 5.0.0 or later running in a cluster (HA) configuration.

Diagnosing the problem

If the Reset command fails, the error will be displayed in Case Manager Builder's console pane. Additionally you can examine both the primary cluster node's Websphere SystemOut.log and the Content Engine server logs for additional details the error that occurred.

Resolving the problem

Stop all other Content Engine (CE) JVM’s except the primary CE cluster node prior to performing the Reset Test Environment command. After the reset is complete restart the other CE JVM’s. If the failure is due to error FNRPA0071E and the security descriptor becomes invalid, perform the procedures in the following Technote.



Note: Review the information in the following link before starting the procedures.

https://www.ibm.com/support/docview.wss?rs=86&uid=swg21613375


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Document information


More support for:

Case Manager

Software version:

5.0.0, 5.1.0

Operating system(s):

AIX, Linux, Linux on System z, Solaris, Windows

Software edition:

All Editions

Reference #:

1613636

Modified date:

2012-11-29

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