Information Server: Unable to connect to WebSphere (WAS)

Technote (troubleshooting)


Problem(Abstract)

Not able to connect to DataStage instance.
WAS service restarts and system reboots does not resolve problem,
On system reboot, the WAS service goes into 30 second wait status then fails. Logs indicate an inability to connect to the repository.

Cause

xmeta password expired at OS level

xmeta userid is the default one recommended, please replace with your xmeta database userid if you are not using the default


Diagnosing the problem

Review the WebSphere SystemOut logs,

Check if WAS service goes into 30 second wait status on restart then fails and that the logs indicate an inability to connect to the repository.


Resolving the problem

XMETA password has expired at the OS level

To recover you have 2 options.

1. Reset xmeta user password back to what it should be

2. Change xmeta password at the OS level and use the following commands to replace the xmeta database password:


<Info Server>\ASBServer\bin\AppServerAdmin.<sh or bat> -db -user xmeta
-password <new password>

NOTE: Use '.sh' when run on Unix and '.bat' when run on Windows


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Document information


More support for:

InfoSphere DataStage

Software version:

8.1, 8.1.0.1, 8.1.0.2, 8.5, 8.5.0.1, 8.5.0.2, 8.5.0.3, 8.7

Operating system(s):

AIX, HP-UX, Linux, Solaris, Windows

Reference #:

1613549

Modified date:

2012-11-30

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