Content files are not removed from the content staging area after being successfully migrated to a fixed content device.

Technote (troubleshooting)


Problem(Abstract)

Content files are not removed from the content staging area after being successfully migrated to a fixed content device.

This issue only applies to customers that have a fixed content device (e.g. EMC Centera®, NetApp SnapLock®), configured with their P8 system and have installed either 5.0.0.1-P8CE-FP001 or 5.1.0.1-P8CE-FP001. It does not apply to releases below 5.0.0.1-P8CE-FP001 and 5.1.0.1-P8CE-FP001. It also does not apply to customers storing their content in either file storage areas or database storage areas.

Cause

In 5.0.0.1-P8CE-FP001 and 5.1.0.1-P8CE-FP001, the naming convention for files in a file storage area was changed to spread files more evenly across directories in the file store structure. Since the content staging area of a fixed storage area is actually a file storage area, it was also affected by this change. A problem has been found in the logic to remove files in the content staging area after they have been successfully migrated to the target fixed content device. No content is lost or incorrectly migrated, however, content files will accumulate in the content staging area. This will unnecessarily consume space on the content staging area disk volume. It may eventually impact further content migration operations if the disk volume used by the content staging area reaches capacity. Retrieval requests are not impacted.

Resolving the problem

For customers with fixed content device configurations that have already installed and are running with 5.0.0.1-P8CE-FP001 or 5.1.0.1-P8CE-FP001, test fixes are available, (5.0.0.1-P8CE-ALL-TF003 and 5.1.0.1-P8CE-ALL-TF007). These must be installed immediately and can be obtained by contacting IBM Support.

To avoid possible confusion with the issue described in this technote IBM recommends that customers do not use 5.0.0.1-P8CE-FP001 or 5.1.0.1-P8CE-FP001. Both of these releases have been removed from Fix Central. Instead, new fix packs are available on these respective product lines (5.0.0.1-P8CE-FP002 and 5.1.0.1-P8CE-FP002) that contain all of the functionality in FP001 and correct the issue described in this technote.

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Document information


More support for:

FileNet Content Manager
Content Engine

Software version:

5.0, 5.1.0

Operating system(s):

AIX, HP-UX, Linux, Solaris, Windows

Software edition:

All Editions

Reference #:

1613523

Modified date:

2013-01-23

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