IBM Support

Launching Amos: No valid license for Amos was found. ( 11, 4).

Troubleshooting


Problem

I launch the Amos software, and I receive the following error: "No valid license for Amos was found. ( 11, 4)."

Symptom

Launch Amos, and I receive the following error:

"No valid license for Amos was found. ( 11, 4)."

Note: In some versions of Amos, if the lservrc file does not exist the first error message will be a Windows Pop-Up stating the following:
"You have not yet run the License Authorization Wizard to activate Amos. Amos will stop running today unless you activate it."

Cause

Please verify that the software was properly installed as per the installation instructions.

The person who installed the software must be logged into the computer as the Local Administrator with administer privileges?



There can be several possible causes for this error:

(1) The software has not yet been activated and therefore no License File (lservrc) has been created.
    Follow the installation instructions for the software version and your operating system to run the license activation wizard and activate your software using the authorization code.

(2) When running the License Authorization Wizard the Licensing File (lservrc) was unable to be created.
    The logged in user does not have the correct permissions to create the license file in the software's installation folder. The software installer should be logged into the computer as the local administrator when activating the license.

(3) The license in the License File (lservrc) is invalid, for another software product, for a different version of the software, or has expired.

(4) The credentials used to log into the computer by the user do not have the correct permissions to read the license file (lservrc). Please see your local IT department for the correct permissions.

Environment

Windows

Resolving The Problem

For what ever reason after the installation of the software the activation process did not complete properly. Just by re-running the license authorization wizard again may correct the problem.


    Note: On the same machine, you will not use up another activation by re-running the license authorization wizard.

1) Run the Amos License Authorization Wizard and activate the Amos Authorization Code.


    Note: For Windows Vista and above operating systems, you must do the following:
    Right-click on the license authorization wizard, and choose “Run as Administrator”

2) Verify the licensing file (lservrc) was created in the Amos installation directory.

3) If the licensing file (lservrc) file exists, open the file with a text editor, and verify there is a license in the file.

4) If your user permissions do not have the correct permissions to read the license file (lservrc), it is as if the file does not exist.

See the "Causes" section in this TechNote for more details.

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Document Information

Modified date:
16 April 2020

UID

swg21613190