Troubleshooting
Problem
You start the installation of IBM Installation Manager. You receive a Java error: "An error has occurred. See the log file C:\Users\MyUser\.eclipse\577987100\configuration\1348696691659.log Installc: Java was started but returned exit code=13"
Symptom
An example of the Java error:
"An error has occurred. See the log file
C:\Users\MyUser\.eclipse\577987100\configuration\1348696691659.log
Installc:
Java was started but returned exit code=13
C:\tmp\Installation#anagerKit\jre_6.0.0.sr9_20110208_03\jre\bin\java.exe
-Xms40m
-Xmx512m
-Xquickstart
-Xgcpolicy:gencon
-jar C:\tmp\Installation#anagerKit\plugins\org.eclipse.equinox.launcher_1.1.1.R36x_v20101122_1400.jar
-os win32
-ws win32
-arch x86
-launcher C:\tmp\Installation#anagerKit\installc.exe
-name Installc
--launcher.library C:\tmp\Installation#anagerKit\plugins\org.eclipse.equinox.launcher.win32.win32.x86_1.1.0.v20100503\eclipse_1307.dll
-startup C:\tmp\Installation#anagerKit\plugins\org.eclipse.equinox.launcher_1.1.1.R36x_v20101122_1400.jar
-exitdata cc4_114
-toolId installc
-accessRights admin
-silent input @osgi.install.area\install.xml
-acceptLicense
-vm C:\tmp\Installation#anagerKit\jre_6.0.0.sr9_20110208_03\jre\bin\java.exe
-vmargs
-Xms40m
-Xmx512m
-Xquickstart
-Xgcpolicy:gencon
-jar C:\tmp\Installation#anagerKit\plugins\org.eclipse.equinox.launcher_1.1.1.R36x_v20101122_1400.jar"
The log file specified by the above error message contains an entry similar to this text:
"!SESSION Thu Aug 16 16:19:54 EDT 2012 ----------------------------------
!ENTRY org.eclipse.equinox.launcher 4 0 2012-08-16 16:19:54.949
!MESSAGE Exception launching the Eclipse Platform:
!STACK
java.lang.RuntimeException: Could not find framework
at org.eclipse.equinox.launcher.Main.getBootPath(Main.java:976)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:555)
at org.eclipse.equinox.launcher.Main.run(Main.java:1408)
at org.eclipse.equinox.launcher.Main.main(Main.java:1384)"
Cause
This issue occurs when the path to the Installation Manager installer contains unsupported characters.
Resolving The Problem
To work around this issue, take the following steps:
1. Copy or move the installation files for Installation Manager to a directory where the path does not contain any of the following characters:
: % # < > "
2. Start the installation of Installation Manager from this directory
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Document Information
Modified date:
25 October 2021
UID
swg21612947