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Connecting to license server results in "Cannot connect to license server system" error in Rational System Architect

Technote (troubleshooting)


Problem(Abstract)

Attempts to connect to a license server using a floating license in IBM Rational System Architect (SA) results in the error "Cannot connect to license server system".

Symptom

The full error message is as follows:

Cannot connect to license server system.

The license server manager (lmgrd) has not been started yet,

the wrong port@host or license file is being used, or the port or hostname in the license file has been changed.

Feature: SA-SystemArchitect

Cause

The IP address of the client is not specified in the TELELOGIC_LICENSE_FILE system environment variable.

Resolving the problem

Use the IP address instead of specifying 127.0.0.1 or hostname in the TELELOGIC_LICENSE_FILE system environment variable as follows:

TELELOGIC_LICENSE_FILE=<port number>@<IP address>

Related information

A Japanese translation is available

Document information

More support for: Rational System Architect
Licensing

Software version: 11.4.2

Operating system(s): Windows

Reference #: 1612695

Modified date: 2012-11-01