Hardware and Software Requirements: Data Protection for VMware Version 6.4

Preventive Service Planning


Abstract

This document details the Hardware and Software requirements for Tivoli Storage Manager for Virtual Environments: Data Protection for VMware 6.4.

Content

The Data Protection for VMware requirements vary by high level functional component. Data Protection for VMware has the following high level functional components:

  • Data Protection for VMware GUI
  • Data Mover
  • Recovery Agent

Note:
All Data Protection for VMware functional components must be at the same Fix Pack level. Within a given fix pack level, the interim fix level can differ.

Examples:
  • When upgrading the Data Protection for VMware GUI from 6.4.0 to 6.4.1, all data movers and recovery agents must be upgraded to 6.4.1.
  • When upgrading a data mover from 6.4.1.3 to 6.4.1.4, it is not required that all other components be upgraded to 6.4.1.4 (but they all must be at 6.4.1.x).

This document is divided into linked sections for ease of navigation. You may use the links below to jump to the desired section of the document.

Supported VMware vCenter Server versions

Data Protection for VMware GUI supported operating systems


Data Mover supported operating systems
Recovery Agent & Recovery Agent Command Line Interface supported operating systems

Additional software requirements and limitations

Hardware requirements for Data Protection for VMware

Where to download Tivoli Storage Manager for Virtual Environments 6.4.0

Hardware and Software requirements for other releases of Data Protection for VMware



Supported VMware vCenter Server versions

The following VMware vCenter Server versions are supported:

  • vCenter Server 4.0
  • vCenter Server 4.1
  • vCenter Server 5.0
Note: 05/27/2014 As per APAR IT01979:
  • indicated that the vCenter Server 5.1 was supported. However, vCenter 5.1 is not supported with the 6.4.
  • doesn't indicated that the vCenter Server 4.0 was supported. However, vCenter 4.0 is supported with the 6.4
This is due to a limitation associated with the VMware VDDK included in the Tivoli Storage Manager (TSM) Backup-Archive Client. The TSM Backup-Archive Client is separately installed prerequisite software which enables the Data Protection for VMware Data Mover functions.



Data Protection for VMware GUI supported operating systems

This functional component integrates the product with the VMware vCenter Server client in order to back up, restore, and manage virtual machines in the VMware vCenter and includes the Data Protection for VMware command-line interface. The supported operating systems by platform are detailed below.


Linux x86_64 platform

The following operating systems are supported for the Data Protection for VMware GUI on the Linux x86_64 platform.
  • Red Hat Enterprise (RHEL) Linux 5 Update 6, and later mod levels and fix packs: Desktop and Advanced Platform Editions
  • Red Hat Enterprise (RHEL) Linux 6, and later mod levels and fix packs: Sever Editions
  • SUSE Enterprise Linux 11, and later mod levels and fix packs: Sever Editions

Note: 05/27/2014 As per APAR IT01979:
  • the minimum level of Red Hat Enterprise (RHEL) Linux 5 was listed as Update 2.
    However, the minimum supported level is actually Update 6.
  • the Red Hat Enterprise (RHEL) Linux 6 support statement indicated that the following editions are supported: Desktop and Advanced Platform Editions.
    However, only the following editions are actually supported: Server Editions
  • the SUSE Enterprise Linux 11 support statement indicated that the following editions are supported:Desktop and Advanced Platform Editions
    However, only the following editions are actually supported: Server Editions


Windows x86 platform

The following operating systems are supported for the Data Protection for VMware GUI on the Windows x86 platform:
  • Windows Server 2008, and later Service Packs: Standard, Enterprise, Datacenter Editions
  • Windows 7, and later Service Packs: Enterprise, Professional, and Ultimate Editions

Note: 05/27/2014 As per APAR IT01979:
  • the Windows Server 2008 support statement indicated that the following editions are supported: Standard, Enterprise, Datacenter, Storage Server, Storage Server R2, Small Business Server, Essential Business Server, and Web Editions
    However, only the following editions are actually supported: Standard, Enterprise, Datacenter Editions


Windows x64 platform

The following operating systems are supported for the Data Protection for VMware GUI on the Windows x64 platform:
  • Windows Server 2008, and later Service Packs: Standard, Enterprise, Datacenter Editions
  • Windows Server 2008 R2, and later Service Packs: Standard, Enterprise, Datacenter Editions
  • Windows 7, and later Service Packs: Enterprise, Professional, and Ultimate Editions

Note: 05/27/2014 As per APAR IT01979:
  • the Windows Server 2008 support statement indicated that the following editions are supported:Standard, Enterprise, Datacenter, Storage Server, Storage Server R2, Small Business Server, Essential Business Server, and Web Editions
    However, only the following editions are actually supported: Standard, Enterprise, Datacenter Editions
  • the Windows Server 2008 R2, support statement indicated that the following editions are supported:Standard, Enterprise, Datacenter, Storage Server, Storage Server R2, Small Business Server, Essential Business Server, and Web Editions
    However, only the following editions are actually supported: Standard, Enterprise, Datacenter Editions



Data Mover supported operating systems

The Data Mover is installed on the vStorage Backup Server and enables off-host block level incremental backups. This function is enabled by the installation of the Tivoli Storage Manager (TSM) Backup-Archive Client 6.4.0, or later maintenance levels and Fix Packs. The TSM Backup-Archive Client is a separate prerequisite and not included in the Data Protection for VMware installation package.

Though the TSM Backup-Archive Client supports a wide variety of operating systems, only a subset of those operating systems are supported with TSM for Virtual Environments.
  • The 6.4.0 level of the TSM Backup-Archive client, or later Fix Packs or interim fixes of this release, is required with Data Protection for VMware 6.4.

WARNING :
The TSM Client API 6.4.0 is also a prerequisite of Data Protection for VMware 6.4.0 and is automatically installed as a part of the Data Protection for VMware 6.4.0 installation process. The TSM Backup-Archive Client and TSM Client API levels must remain in sync in your complete environment. Therefore, future updates to either the TSM Backup-Archive Client or the TSM Client API require that the other component be updated at the same time. I.e. if you install a new Fix Pack level of the TSM Backup-Archive client, you need to upgrade the TSM Client API to the exact same level on your Data Protection for VMware systems and vice versa. See also " Upgrading to Tivoli Storage Manager for Virtual Environments Version 6.4"

The VMware Virtual Disk Development Kit (VDDK) version 5.1 runtime files are used for backing up virtual machines by the Data Mover.
Data Mover / TSM Backup-Archive Client with Data Protection for VMware supports the operating systems listed below, as long as they are also supported by VDDK version 5.1.
For updates on supported OSes, known issues and limitations regarding VDDK 5.1 see the VMware web site.

The Data Protection for VMware data mover utilizes VMware's Virtual Disk Development Kit (VDDK) API's to open, close, read and write virtual disk data (VMDKs). To determine the level of VDDK used in each level of Data Protection for VMware, as well as compatible ESX/ESXi builds supported by the VDDK level, please refer to the tech note:

    Tivoli Storage Manager for Virtual Environments: Data Protection for VMware data mover compatibility guide with VMware's Virtual Disk Development Kit
located here http://www.ibm.com/support/docview.wss?uid=swg21672351


The supported operating systems by platform for the Data Mover / TSM Backup-Archive Client with Data Protection for VMware are detailed below.


Linux x86_64 platform

The following operating systems are supported for the Data Mover on the Linux x86_64 platform:

  • Red Hat Enterprise (RHEL) Linux 5 Update 3, Update 4, and Update 5: Desktop and Advanced Platform Editions
  • Red Hat Enterprise (RHEL) Linux 6 Update 1 and Update 2: Desktop and Advanced Platform Editions
  • SUSE Enterprise Linux 10 SP2: Desktop and Server Editions
  • SUSE Enterprise Linux 11 SP2: Desktop and Server Editions

Note: Consistent backup failures have been experienced with some data movers. The issue has been fixed with IC88237 which is included in the TSM Backup-Archive client 6.4.0.1 interim fix, available since January 31, 2013.


Windows x86 platform

The following operating systems are supported for the Data Mover on the Windows x86 platform:
  • Windows 7, and later Service Packs: Enterprise, Home Premium, Professional, Starter, and Ultimate Editions

Note: Windows 8 is not supported at this time.


Windows x64 platform

The following operating systems are supported for the Data Mover on the Windows x64 platform:
  • Windows Server 2008 R2, and later Service Packs: Standard, Enterprise, Datacenter, Storage Server, Storage Server R2, Small Business Server, Essential Business Server, and Web Editions
  • Windows 7, and later Service Packs: Enterprise, Home Premium, Professional, and Ultimate Editions
Not e: Windows 8 and Windows Server 2012 are not supported at this time.



Recovery Agent supported operating systems

This function provides virtual mount and instant restore capabilities. The supported operating systems by platform are detailed below.


Linux x86_64 Platform

The following operating systems are supported for the Recovery Agent on the Linux x86_64 platform:
  • Red Hat Enterprise (RHEL) Linux 51 Update 2, and later mod levels and fix packs: Desktop and Advanced Platform Editions
  • Red Hat Enterprise (RHEL) Linux 61, and later mod levels and fix packs: Desktop and Advanced Platform Editions
  • SUSE Enterprise Linux 10 SP2, and later mod levels and fix packs: Desktop and Server Editions
  • SUSE Enterprise Linux 11, and later mod levels and fix packs: Desktop and Server Editions

Note:
  1. Requires the following minimum packages and their dependencies:
    • compat-db-4.6.21-15
    • libXp-1.0.0-15.1
    • libXmu-1.0.5-1
    • libXtst-1.0.99.2-3
    • pam-1.1.1-4
    • libXft-2.1.13-4.1
    • gtk2-2.18.9-4
    • gtk2-engines-2.18.4-5
    The Recovery Agent Command Line Interface (CLI) is not supported on the Linux x86_64 platform.


    Windows x86 Platform

    The following operating systems are supported for the Recovery Agent on the Windows x86 platform:
    • Windows Server 2008 SP1, and later Service Packs: Standard, Enterprise, Datacenter, Storage Server, Storage Server R2, Small Business Server, Essential Business Server, and Web Editions
    • Windows Vista SP1, and later Service Packs: Business, Enterprise, Home Basic, Home Premium, Starter, and Ultimate Editions
    • Windows 7, and later Service Packs: Enterprise, Home Premium, Professional, Starter, and Ultimate Editions
    • Windows 8, Professional and Enterprise Editions

    No te: If you use Active Directory with Microsoft Windows 2008 or Microsoft Windows 2008 R2, install the hot fix associated with Microsoft Knowledge Base article 970770 at:
    http://support.microsoft.com/default.aspx?scid=kb;EN-US;970770


    Windows x64 Platform

    The following operating systems are supported for the Recovery Agent on the Windows x64 platform:
    • Windows Server 2008 SP1, and later Service Packs: Standard, Enterprise, Datacenter, Storage Server, Storage Server R2, Small Business Server, Essential Business Server, and Web Editions
    • Windows Server 2008 R2, and later Service Packs: Standard, Enterprise, Datacenter, Storage Server, Storage Server R2, Small Business Server, Essential Business Server, and Web Editions
    • Windows Vista SP1, and later Service Packs: Business, Enterprise, Home Premium, Starter, and Ultimate Editions
    • Windows 7, and later Service Packs: Enterprise, Home Premium, Professional, and Ultimate Editions
    • Windows 8, Professional and Enterprise Editions
    • Windows Server 2012

    Note: If you use Active Directory with Microsoft Windows 2008 or Microsoft Windows 2008 R2, install the hot fix associated with Microsoft Knowledge Base article 970770 at
    http://support.microsoft.com/default.aspx?scid=kb;EN-US;970770



    Additional software requirements and limitations

    The following additional software is required to use Data Protection for VMware:
    • Tivoli Storage Manager (TSM Server) 6.2 and later interim fixes and fix packs
    • Tivoli Storage Manager (TSM Server) 6.3 and later interim fixes and fix packs
    • Tivoli Storage Manager (TSM Server) 7.1 and later interim fixes and fix packs

    • The Recovery Agent and VMware vCenter Plugin require the following supporting applications on Linux:
      • Perl version 5
      • mdadm 2.6 tool for managing Linux Software RAID arrays
      • iSCSI Initiator 6.2 for Linux package
      • lsscsi command version 0.23
      • iscsiadm utility 0.10
      • Secure Shell (SSH) client for Linux 0.1

    • The Data Protection for VMware GUI on Windows requires Microsoft Internet Explorer version 8 or 9 to be installed on the system where the plug-in will be launched.

    • The application-aware log truncation function is not supported with guests running in ESX/ESXi 4.1

    • The fix for IC88083 is required to use the 6.4 Data Mover to include or exclude individual disks from backup when connecting to a VMware vCenter Server running in a Japanese, Korean, or Simplified Chinese locale. This fix is included in the TSM backup-archive client 6.4.0.1 interim fix, available since January 31, 2013.


    Hardware requirements for Data Protection for VMware

    Hardware requirements vary and depend on the following items:
    • Number of protected servers
    • Number of protected volumes
    • Data set sizes
    • LAN and SAN connectivity

    The following table describes the hardware requirements that are needed to install
    Data Protection for VMware.

    Component Minimal requirement Preferred
    System IntelPentium D 3 GHz Dual Core processor or compatible Not applicable
    Memory 2 GB RAM, 2 GB virtual
    address space
    Not applicable
    Available hard disk 200 MB for 'Documents and
    Settings' folder
    2 GB
    NIC Card 1 NIC - 100 Mbps 1 NIC - 1 Gbps



    Where to download Tivoli Storage Manager for Virtual Environments 6.4.0

    The Tivoli Storage Manager for Virtual Environments download document provides information about how and where to obtain the Tivoli Storage Manager for Virtual Environments 6.4.0 package. The information is located at: http://www.ibm.com/support/docview.wss?uid=swg24033103

    TIP: Data Protection for VMware 6.4.0 is a component of Tivoli Storage Manager for Virtual Environments 6.4.0



    Hardware and Software requirements for other releases of Data Protection for VMware

    The Hardware and Software requirements for other releases and fix packs of Data Protection for VMware are located in the "Tivoli Storage Manager for Virtual Environments - All Requirements Doc" located at: http://www.ibm.com/support/docview.wss?uid=swg21505139

    Related information

    All Requirements Doc TSM for Virtual Environments
    Download Tivoli Storage Manager for Virtual Environment

    Rate this page:

    (0 users)Average rating

    Add comments

    Document information


    More support for:

    Tivoli Storage Manager for Virtual Environments
    Data Protection for VMware

    Software version:

    6.4

    Operating system(s):

    Linux, Windows

    Reference #:

    1611903

    Modified date:

    2014-06-10

    Translate my page

    Machine Translation

    Content navigation