Build Engine Test connection results in Authentication Failed error

Technote (troubleshooting)


Attempts to test the connection in the build engine editor for a IBM Rational Build Forge build agent causes an Authentication Failed error when using IBM Rational Team Concert


When testing the connection, the following error will occur:

Message: Socket created successfully.
AUTH Unable to set user account to *AuthIllegal ("<Username>")
Authentication Failed.


The password saved from the deprecated testConnection method is a standard password without UTF-8 encoding.  The tasks are using the testConnection2 method and will run, even though the password fails with the earlier testConnection method. 

This behaviour was filed under work item 229212.

Environment client and servers.

Resolving the problem


Re-enter the password in the engine editor (and not save) before testing the connection.

Leverage the Jazz Community

Jazz and Rational Team Concert have an active community that can provide you with additional resources. Browse and contribute to the User forums, contribute to the Team Blog and review the Team wiki.
Refer to technote 1319600 for details and links.

Cross reference information
Segment Product Component Platform Version Edition
Software Development Rational Build Forge Linux, Windows 7.0.1, 7.0.2

Document information

More support for:

Rational Team Concert

Software version:,

Operating system(s):

Linux, Windows

Reference #:


Modified date:


Translate my page

Content navigation