Using the DSXImportService and SyncProject .sh or bat files can generate a permission denied error

Technote (troubleshooting)


Problem(Abstract)

Customers running the java command line apps DSXImportService and SyncProject will have orb trace files generated in the directory from where the application is being run. Sometimes, the user does not have sufficent rights for the file to be written to the directory and an exception is created and displayed. The exception does not interrupt application processing.

Symptom

When running either the DSXImportService or SyncProject command an exception statement displays within the command window. Example:

C:\IBM\InformationServer\ASBNode\bin>SyncProject.bat
com.ibm.rmi.ras.Utility.newWriter: could not write to orbtrc.18092012.1654.58.tx
t : java.io.FileNotFoundException: C:\IBM\InformationServer\ASBNode\bin\orbtrc.1
8092012.1654.58.txt (Access is denied.)

Cause

The DSXImportService and SyncProject applications attempts to create the orbtrc files in the directory from which the application is being run. If the user does not have sufficient write access privileges to this directory, an exception message is generated.






Resolving the problem

To prevent the exception, perform one of the following steps:

  • Modify the permission to the directory to which the orb trace file is being written.
  • Run the application from a directory that you have write access to.
Alternatively, you can just ignore the exception message. The message does not affect the processing of the command.

Cross reference information
Segment Product Component Platform Version Edition
Information Management InfoSphere Information Server AIX, HP-UX, Linux, Solaris, Windows 9.1

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

InfoSphere DataStage

Software version:

9.1

Operating system(s):

AIX, HP-UX, Linux, Solaris, Windows

Reference #:

1611442

Modified date:

2012-12-14

Translate my page

Machine Translation

Content navigation