Error # 2072 Specific symptom number: 4 Mac OS X There was an unanticipated problem with the license for this product.

Technote (troubleshooting)


Problem(Abstract)

Launching Statistics on a Apple MacBook Air, MacBook Pro, iMac, or Mac mini using Thunderbolt Technology.

‘Error # 2072

There was an unanticipated problem with the license for this product.

Execution of this command stops. >Specific symptom number: 4’

Symptom

Launching Statistics on a Apple MacBook Air, MacBook Pro, iMac, or Mac mini using Thunderbolt Technology.
----------------------------------------
Pop-Up Entitled: IBM SPSS Statistics 20 or 21 (depending on installed version of Statistics)
.........................
'There was an unanticipated problem with the license for this product.
Specific symptom number: 4'
Followed by an [OK] button.
----------------------------------------
Error Message in Statistics Output Window (.spv):
.........................
>Error # 2072
>There was an unanticipated problem with the license for this product.
>Execution of this command stops. >Specific symptom number: 4


Cause

Booting the Mac OS X ThunderBolt Monitor versus the Laptop Monitor uses a different lock code of 10-, therefore the device used to activate the license is the one that the license is tethered to.

Resolving the problem

Changing the locking code from using a "10-" to a "4-".

Depending of the version of Statistics installed:
You will need to know the path of where IBM SPSS Statistics 20.0 is installed.
The Default path is:
/Applications/IBM/SPSS/Statistics/20/SPSSStatistics.app/Contents/bin
--OR--
You will need to know the path of where IBM SPSS Statistics 21.0 is installed.
The Default path is:
/Applications/IBM/SPSS/Statistics/21/SPSSStatistics.app/Contents/bin

============================================
1) Open up FINDER
2) Open up the APPLICATIONS folder
3) Open up the IBM folder
4) Open up the SPSS folder
5) Open up the Statistics folder
6) Open up the 20 or 21 folder (depending on installed version of Statistics)
7) Locate SPSSStatistics.app and do a Control + Click (for the contextual menu), and choose Show Package Contents
8) Open up the Contents folder
9) Open up the bin folder
10) Locate and Control Click echoid.dat and choose Open With, and then choose
TextEdit.app
11) Change the 0x010 to 0x004
12) Save the echoid.dat file
13) Delete the current lservrc file in this directory (if one exists, if not continue)
14) Run the License Authorization Wizard (LAW)
15) Re-launch Statistics 20.0 or 21.0. The software should launch without error.

============================================
Another work around would be to use a Concurrent License vs. a Single or Site License.
A concurrent license does not use the locking code of the users computer, as the license is activated on a separate machine using Sentinel Licensing Manager technology. This technology is usually set up on a server and the client is pointed to this server during installation.

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Document information


More support for:

SPSS Statistics

Software version:

20.0, 21.0

Operating system(s):

Mac OS

Reference #:

1611352

Modified date:

2014-07-01

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