IBM Support

db2_install or db2icrt fails with memory corruption error on Ubuntu OS

Technote (troubleshooting)


Problem(Abstract)

In DB2 V10 FP0 db2_install or db2icrt fails with memory corruption error on Ubuntu OS
Following error can be seen during db2icrt or db2_install

DB2 installation is being initialized.
*** glibc detected *** /opt/ibm/db2/V10.1/instance/native/install/db2iure: malloc(): memory corruption (fast): 0x0000000000c17590 ***
======= Backtrace: =========
/lib/libc.so.6(+0x775b6)[0x7f50d6bfa5b6]
/lib/libc.so.6(+0x7b8e9)[0x7f50d6bfe8e9]
/lib/libc.so.6(__libc_malloc+0x6e)[0x7f50d6bff58e]
/usr/lib/libstdc++.so.6(_Znwm+0x1d)[0x7f50d71e826d]
/usr/lib/libstdc++.so.6(_Znam+0x9)[0x7f50d71e8389]

Symptom

db2icrt or db2_install fails with memory corruption.


Cause

RPM utility not installed on Ubuntu OS

Environment

DB2 V10 FP0 and Ubuntu OS

Resolving the problem

This can be resolved by either of the following options:


- Install RPM utility
- Upgrade to V10 FP1

Document information

More support for: DB2 for Linux, UNIX and Windows
Corruption - Memory

Software version: 10.1

Operating system(s): Linux

Reference #: 1611103

Modified date: 18 November 2015


Translate this page: