IBM Support

SSO through TAM WebSEAL redirects to Cognos Connection login page.

Troubleshooting


Problem

When users attempt to perform Single Sign-On via TAM WebSEAL to Cognos Business Intelligence they are prompted to sign in to the Cognos Connection login page. A Tivoli Access Manager junction is properlty defined for Cognos.

Symptom

Users are presented with multiple sign-on requests.

Cause

In Cognos Configuration on the Cognos Content Manager, the "Use external identity?" property of the LDAP namespace is set to False.

Resolving The Problem

Set the "Use external identity?" property of the namespace to True:
<ol>
<li>On the Content Manager system(s), Open Cognos Configuration.</li>
<li>Navigate to Environment -> Security -> Authentication and select the LDAP namespace.</li>
<li>On the Resource Properties page of the LDAP namespace, change "Use external identity?" to True.</li>
<li>Save the Cognos Configuration and restart the Cognos environment.</li>
</ol>

[{"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Install and Config","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"10.2;10.2.1;10.2.2","Edition":"Edition Independent","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21610968