Troubleshooting
Problem
An error occurs starting IBM Cognos Configuration.
A fatal error has occurred. Unable to run the application.
An exception occurred.
java.lang.UnsatisfiedLinkError: JCAM_Crypto_JNI (not found in java.library.path)
Symptom
Cause
The PATH environmental variable referred to C:\Program Files (x86)\IBM\cognos\c10\bin. In the other reported occurrence, PATH contained C:\Program Files\ibm\cognos\c10_64\bin
Environment
Windows 64-bit
Diagnosing The Problem
Check the directories defined in the PATH environmental variable.
Resolving The Problem
Alter the PATH variable to either remove the reference to the directory or alternatively add ...\c10_64\bin64 before the reference to the other IBM Cognos directories.
[{"Type":"SW","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSQJVQ","label":"IBM Cognos PowerPlay"},"ARM Category":[{"code":"a8m50000000Cl6sAAC","label":"Installation and Configuration->Cognos Configuration"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)"},{"Type":"SW","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"ARM Category":[{"code":"a8m50000000Cl6OAAS","label":"Installation and Configuration->Authentication"}],"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)"}]
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Document Information
Modified date:
30 April 2021
UID
swg21610845