Hardware and Software Requirements: V5.5.6 Data Protection for Microsoft SQL Server

Preventive Service Planning


Abstract

This document details the Hardware & Software requirements for Data Protection for Microsoft SQL Server V5.5.6. This Fix Pack can also be installed into FlashCopy Manager for Microsoft SQL 2.2.1.x environments.

Content

The requirements that follow are for the Data Protection for Microsoft SQL V5.5.6 Fix Pack which is a part of the IBM Tivoli Storage Manager for Databases V5.5 product.


    Note: If you are an existing Data Protection for SQL 5.5.5 user, the requirements for the 5.5.6 Fix Pack are almost identical to the requirements for the 5.5.5 Fix Pack. The only updated requirements between 5.5.5 and 5.5.6 relate to the Tivoli Storage Manager API Client and Tivoli Storage Manager Backup-Archive Client.

Tivoli Storage FlashCopy Manager customers may install the Data Protection for Microsoft SQL 5.5.6 Fix Pack into their FlashCopy Manager for Microsoft SQL 2.2.1.x environment in order to take advantage of the fixes provided in this Fix Pack.


Links to the Hardware & Software requirements for other releases of Tivoli Storage Manager for Databases, and its components, are located in the "All Requirements Doc" located at the following URL: http://www.ibm.com/support/docview.wss?uid=swg21218747

Links to the Hardware & Software requirements for the other components that are a part of IBM Tivoli Storage FlashCopy Manager V2.2.1, are located at the following URL: http://www.ibm.com/support/docview.wss?uid=swg21455746


Links to the Hardware & Software requirements for other releases of IBM Tivoli Storage FlashCopy Manager, and its components, are located in the "All Requirements Doc" located at the following URL: http://www.ibm.com/support/docview.wss?uid=swg21427692

Information regarding virtualization technologies supported by the Tivoli Storage Manager Family of Products is available in the IBM Tivoli Storage Manager (TSM) guest support for Virtual Machines and Virtualization tech note located at the following at the following URL: http://www.ibm.com/support/docview.wss?&uid=swg21239546

Information regarding virtualization technologies supported by IBM Tivoli Storage Manager FlashCopy Manager is available in the FlashCopy Manager Virtualization Support tech note located at the following at the following URL: http://www.ibm.com/support/docview.wss?uid=swg21433737

The Data Protection for SQL V5.5.6 download document provides information about how and where to obtain the Data Protection for SQL V5.5.5 packages. The information is located here:
http://www.ibm.com/support/docview.wss?uid=swg24033437

This document is divided into linked sections for ease of navigation. You may use the links below to jump to the desired section of the document.


Requirements for the x86 Platform
Requirements for the x64 Platform
Requirements for the IA64 Platform
VSS Provider Requirements
Requirements for Using VSS Functions

Additional Requirements for Using VSS Off-loaded Backup Operations
Additional Requirements for VSS Instant Restore Operations


Requirements for the x86 Platform

Hardware:
  • 32-bit Intel Pentium 166, or higher machine
  • Compatible hardware supported by the operating system and the application
  • At least 96 MB of RAM
  • At least 60 MB of disk space

Software:
  • 32-bit Windows Server 2003 SP2, or later Service Pack levels: Standard, Enterprise, or Data Center editions
  • 32-bit Windows Server 2003 R2 SP2, or later Service Pack levels: Standard, Enterprise, or Data Center editions
  • 32-bit Windows Server 2008 SP2, or later Service Pack levels: Standard, Enterprise, or Data Center editions
  • Microsoft SQL Server 2000 SP4 or later Service Pack levels: Standard or Enterprise Editions
      Note: The Tivoli Storage FlashCopy Manager product does not support Microsoft SQL Server 2000.
  • Microsoft SQL Server 2005 SP3, or later Service Pack levels: Standard or Enterprise Editions
  • Microsoft SQL Server 2008 SP1, or later Service Pack levels: Standard or Enterprise Editions
  • Microsoft SQL Server 2008 R2, or later Service Pack levels: Standard, Enterprise, or Data Center Editions


The following prerequisites are also required, and are installed automatically by Data Protection for Microsoft SQL V5.5.6, if not already present on your machine:
    Note: All of these prerequisites are downward compatible with SQL Server 2005 and SQL Server 2000.
  • Microsoft .NET Framework version 2.0, and later releases and versions
  • Microsoft Core XML Services (MSXML) 6.0, and later releases and versions
  • Microsoft SQL Server 2008 Native Client SP1, and later 2008 levels
  • Microsoft SQL Server 2008 Management Objects SP1, and later 2008 levels
  • Microsoft SQL Server System CLR Types

Additional Operating Environments Supported:

  • Microsoft Virtual Server 2005 R2 SP1 guest instances
  • Microsoft Cluster Server (MSCS) / Windows Failover Clustering and Veritas Cluster Server (VCS) environments

Additional Requirements for Storage of Backups in a TSM Server:

  • Any Tivoli Storage Manager Server currently in support
  • The Tivoli Storage Manager API Client V6.2.4, and later 6.2.x levels, releases, and versions
      Note: The Tivoli Storage Manager API Version 6.2.4 on the x86 platform is included and automatically installed with Data Protection for Microsoft SQL V5.5.6.

Additional Requirements for the Use of TSM Central Scheduling:
  • The Tivoli Storage Manager Backup-Archive Client V6.2.4, and later 6.2.x levels, releases, and versions


Additional Requirements when using TSM for Copy Services with Data Protection for SQL 5.5.6:
  • Install the Data Protection for Microsoft SQL VSS Integration Module V5.5.2, or later 5.5.x levels, releases, and versions
      Note: This module is only required if you create local or offloaded VSS backups, and restore from them.



Requirements for the x64 Platform

Hardware:
  • 64-bit Intel EMT64, AMD Opteron, or higher machine
  • Compatible hardware supported by the operating system and the application
  • At least 96 MB of RAM
  • At least 40 MB of disk space

Software:
  • 64-bit Windows Server 2003 SP2, or later Service Pack levels: Standard x64, Enterprise x64, or Data Center x64 editions
  • 64-bit Windows Server 2003 R2 SP2, or later Service Pack levels: Standard x64, Enterprise x64, or Data Center x64 editions
  • 64-bit Windows Server 2008 SP2, or later Service Pack levels: Standard x64, Enterprise x64, or Data Center x64 editions
  • 64-bit Windows Server 2008 R2, or later Service Pack levels: Standard x64, Enterprise x64, or Data Center x64 editions
  • Microsoft SQL Server 2005 SP3, or later Service Pack levels: Standard x64 or Enterprise x64 Editions
  • Microsoft SQL Server 2008 SP1, or later Service Pack levels: Standard x64 or Enterprise x64 Editions
  • Microsoft SQL Server 2008 R2, or later Service Pack levels: Standard, Enterprise, or Data Center Editions


The following prerequisites are also required, and are installed automatically Data Protection for Microsoft SQL V5.5.6, if not already present on your machine:
    Note: All of these prerequisites are downward compatible with SQL Server 2005 and SQL Server 2000.
  • Microsoft .NET Framework version 2.0, and later releases and versions
  • Microsoft Core XML Services (MSXML) 6.0, and later releases and versions
  • Microsoft SQL Server 2008 Native Client SP1, and later 2008 levels
  • Microsoft SQL Server 2008 Management Objects SP1, and later 2008 levels
  • Microsoft SQL Server System CLR Types

Additional Operating Environments Supported:

  • Microsoft Virtual Server 2005 R2 SP1 guest instances
  • Microsoft Cluster Server (MSCS) / Windows Failover Clustering and Veritas Cluster Server (VCS) environments

Additional Requirements for Storage of Backups in a TSM Server:

  • Any Tivoli Storage Manager Server currently in support
  • The Tivoli Storage Manager API Client V6.2.4, and later 6.2.x levels, releases, and versions
      Note: The Tivoli Storage Manager API Version 6.2.4 on the x64 platform is included and automatically installed with Data Protection for Microsoft SQL V5.5.6.

Additional Requirements for the Use of TSM Central Scheduling:
  • The Tivoli Storage Manager Backup-Archive Client V6.2.4, and later 6.2.x levels, releases, and versions


Additional Requirements when using TSM for Copy Services with Data Protection for SQL 5.5.5:
  • Install the Data Protection for Microsoft SQL VSS Integration Module V5.5.2, or later 5.5.x levels, releases, and versions
      Note: This module is only required if you create local or offloaded VSS backups, and restore from them.


Requirements for the IA64 Platform
    Note: This platform is only supported with Data Protection for SQL legacy backups.

Hardware:
  • 64-bit Intel Itanium 64-bit chipset, or higher machine
  • Compatible hardware supported by the operating system and the application
  • At least 96 MB of RAM
  • At least 20 MB of disk space

Software:
  • 64-bit Windows Server 2003 SP2, or later Service Pack levels: Standard, Enterprise, or Data Center editions for Itanium-based systems
  • 64-bit Windows Server 2003 R2 SP2, or later Service Pack levels: Enterprise, or Data Center editions for Itanium-based systems
  • Windows Server 2008 SP2 for Itanium-Based Systems, or later Service Pack levels
  • Windows Server 2008 R2 for Itanium-Based Systems, or later Service Pack levels
  • Microsoft SQL Server 2000 SP4 or later Service Pack levels: Standard or Enterprise Editions
      Note: The Tivoli Storage FlashCopy Manager product does not support Microsoft SQL Server 2000.
  • Microsoft SQL Server 2005 SP3, or later Service Pack levels: Standard or Enterprise Editions for Itanium-based systems
  • Microsoft SQL Server 2008 SP1, or later Service Pack levels: Standard or Enterprise Editions for Itanium-based systems
  • Microsoft SQL Server 2008 R2, or later Service Pack levels: Standard, Enterprise, or Data Center Editions for Itanium-based systems


The following prerequisites are also required, and are installed automatically by Data Protection for Microsoft SQL V5.5.6, if not already present on your machine:
      Note: All of these prerequisites are downward compatible with SQL Server 2005 and SQL Server 2000.
  • Microsoft .NET Framework version 2.0, and later releases and versions
  • Microsoft Core XML Services (MSXML) 6.0,, and later releases and versions
  • Microsoft SQL Server 2008 Native Client SP1, and later 2008 levels
  • Microsoft SQL Server 2008 Management Objects SP1, and level 2008 levels
  • Microsoft SQL Server System CLR Types

Additional Operating Environments Supported:

  • Microsoft Virtual Server 2005 R2 SP1 guest instances
  • Microsoft Cluster Server (MSCS) / Windows Failover Clustering and Veritas Cluster Server (VCS) environments

Additional Requirements for Storage of Backups in a TSM Server:

  • Any Tivoli Storage Manager Server currently in support
  • The Tivoli Storage Manager API Client V6.1.5, and later 6.1.x levels, releases, and versions
      Note: The Tivoli Storage Manager API Version 6.1.5 on the IA64 platform is included and automatically installed with Data Protection for Microsoft SQL V5.5.6.

Additional Requirements for the Use of TSM Central Scheduling:
  • The Tivoli Storage Manager Backup-Archive Client V6.1.5, and later 6.1.x levels, releases, and versions


Additional Requirements when using TSM for Copy Services with Data Protection for SQL 5.5.5:
  • Install the Data Protection for Microsoft SQL VSS Integration Module V5.5.2, or later 5.5.x levels, releases, and versions
      Note: This module is only required if you create local or offloaded VSS backups, and restore from them.

VSS Provider Requirements
The VSS provider is the snapshot component used to create and manage the volume shadow copies. This component may be implemented in software or in a VSS capable storage subsystem that strictly adheres to the Microsoft VSS provider interface.

Refer to the documentation that was shipped with your VSS Provider in order to understand the software and hardware requirements of your specific VSS Provider.

FlashCopy Manager for Microsoft SQL and Data Protection for Microsoft SQL will support any VSS Provider that strictly adheres to the Microsoft VSS Provider interface.

When using a VSS Hardware providers, The following Microsoft Hot Fixes must be applied:

Requirements for Using VSS Functions

The following items define the requirements for VSS Functions depending on whether you use FlashCopy Manager for Microsoft SQL or Data Protection for Microsoft SQL in your environment.

      Note 1: Microsoft SQL Server 2000 is not supported with VSS operations.

When using the Data Protection for Microsoft SQL component in combination with the TSM for Copy Services product, you must:

  • Satisfy the requirements of either the Requirements for the x86 Platform, Requirements for the x64 Platform, or Requirements for the IA64 Platform previously listed in this document, as applicable to your environment
  • Have at least 200 MB of disk space on your Windows system drive to hold meta data files
  • Satisfy the VSS Provider Requirements previously listed in this document
  • Install the Tivoli Storage Manager Windows Backup-Archive Client V6.2.2, and later 6.2.x levels, releases, and versions

  • Use one of the following storage device options:
    • one of the IBM System Storage DS3000/DS4000/DS5000 family of devices, as supported by the LSI Microsoft VDS/VSS Provider v10.60
    • IBM System Storage SAN Volume Controller (SVC) v4.2.0, and later 4.2.x levels, as supported by the IBM System Storage VSS Hardware provider 4.0, and later 4.0.x levels, releases, and versions
    • IBM System Storage SAN Volume Controller (SVC) v4.3.0, and later 4.3.x levels, as supported by the IBM System Storage VSS Hardware provider 4.0, and later 4.0.x levels, releases, and versions
    • IBM System Storage SAN Volume Controller (SVC) v5.1.0, and later 5.1.x levels, as supported by the IBM System Storage VSS Hardware provider 4.1, and later 4.1.x levels, releases, and versions
    • IBM System Storage SAN Volume Controller (SVC) v6.1.0, and later 6.1.x levels, as supported by the IBM System Storage VSS Hardware provider 4.2, and later 4.2.x levels, releases, and versions
    • IBM System Storage SAN Volume Controller (SVC) v6.2.0, and later 6.2.x levels, as supported by the IBM System Storage VSS Hardware provider 4.2, and later 4.2.x levels, releases, and versions
    • IBM Storwize® V7000 Disk System as supported by the IBM System Storage VSS Hardware provider 4.2, and later 4.2.x levels, releases, and versions
    • IBM XIV Storage System Model 2810 (Gen2), as supported by the IBM System Storage XIV xProv VSS Provider 2.2.3, and later 2.2.x levels, releases, and versions
    • IBM XIV Storage Subsystems as supported by the XIV Provider for Microsoft Windows Volume Shadow Copy Service 2.3, and later 2.3.x levels, releases, and versions
    • IBM System Storage DS8000™ (DS8100, DS8300, or DS8700) with DS8000 Release Version 3.1.1, and later 3.1.x levels, releases, and versions, as supported by the IBM System Storage VSS Hardware provider 4.0, and later 4.0.x levels, releases, and versions
    • Any storage devices that implements the VSS provider interface as defined in the VSS Provider Requirements section of this document

When using the Data Protection for Microsoft SQL component in combination with the Tivoli Storage FlashCopy Manager product, you must:

  • Satisfy the requirements of either the Requirements for the x86 Platform or Requirements for the x64 Platform previously listed in this document, as applicable to your environment
  • Satisfy the VSS Provider Requirements previously listed in this document
  • Install the VSS Requestor component of the FlashCopy Manager product

  • Use one of the following storage device options:
    • one of the IBM System Storage DS3000/DS4000/DS5000 family of devices, as supported by the LSI Microsoft VDS/VSS Provider v10.60
    • IBM System Storage SAN Volume Controller v4.2.0, and later 4.2.x levels, as supported by the IBM System Storage VSS Hardware provider 4.0, and later 4.0.x levels, releases, and versions
    • IBM System Storage SAN Volume Controller v4.3.0, and later 4.3.x levels, as supported by the IBM System Storage VSS Hardware provider 4.0, and later 4.0.x levels, releases, and versions
    • IBM System Storage SAN Volume Controller v5.1.0, and later 5.1.x levels, as supported by the IBM System Storage VSS Hardware provider 4.1, and later 4.1.x levels, releases, and versions
    • IBM System Storage SAN Volume Controller v6.1.0, and later 6.1.x levels, as supported by the IBM System Storage VSS Hardware provider 4.2, and later 4.2.x levels, releases, and versions
    • IBM Storwize® V7000 Disk System as supported by the IBM System Storage VSS Hardware provider 4.2, and later 4.2.x levels, releases, and versions
    • IBM XIV Storage System Model 2810 (Gen2), as supported by the IBM System Storage XIV xProv VSS Provider 2.2.3, and later 2.2.x levels, releases, and versions
    • IBM XIV Storage Subsystems as supported by the XIV Provider for Microsoft Windows Volume Shadow Copy Service 2.3, and later 2.3.x levels, releases, and versions
    • IBM System Storage DS8000™ (DS8100, DS8300, or DS8700) with DS8000 Release Version 3.1.1, and later 3.1.x levels, releases, and versions, as supported by the IBM System Storage VSS Hardware provider 4.0, and later 4.0.x levels, releases, and versions
    • Any storage devices that implements the VSS provider interface as defined in the VSS Provider Requirements section of this document

Additional Requirements for Using VSS Off-loaded Backup Operations

In order to use VSS Off-loaded operations, you must:

  • Satisfy the requirements of either the Requirements for the x86 Platform, Requirements for the x64 Platform, or Requirements for the IA64 Platform previously listed in this document, as applicable to your environment
  • Satisfy the VSS Provider Requirements previously listed in this document
  • Satisfy the requirements defined for VSS Functions previously listed in this document
  • Use a VSS provider that supports transportable shadow copies.

Additional Requirements for VSS Instant Restore Operations

In order to use VSS Instant Restore Operations, you must:

  • Satisfy the requirements of either the Requirements for the x86 Platform, Requirements for the x64 Platform, or Requirements for the IA64 Platform previously listed in this document, as applicable to your environment
  • Satisfy the VSS Provider Requirements previously listed in this document
  • Satisfy the requirements defined for VSS Functions previously listed in this document
  • Use one of the following storage device options:
    • IBM System Storage SAN Volume Controller v4.2.0, and later 4.2.x levels, as supported by the IBM System Storage VSS Hardware provider 4.0, and later 4.0.x levels, releases, and versions
    • IBM System Storage SAN Volume Controller v4.3.0, and later 4.3.x levels, as supported by the IBM System Storage VSS Hardware provider 4.0, and later 4.0.x levels, releases, and versions
    • IBM System Storage SAN Volume Controller v5.1.0, and later 5.1.x levels, as supported by the IBM System Storage VSS Hardware provider 4.1, and later 4.1.x levels, releases, and versions
    • IBM System Storage SAN Volume Controller v6.1.0, and later 6.1.x levels, as supported by the IBM System Storage VSS Hardware provider 4.2, and later 4.2.x levels, releases, and versions
    • IBM Storwize® V7000 Disk System as supported by the IBM System Storage VSS Hardware provider 4.2, and later 4.2.x levels, releases, and versions
    • IBM XIV Storage System Model 2810 (Gen2), as supported by the IBM System Storage XIV xProv VSS Provider 2.2.3, and later 2.2.x levels, releases, and versions
    • IBM XIV Storage Subsystems as supported by the XIV Provider for Microsoft Windows Volume Shadow Copy Service 2.3, and later 2.3.x levels, releases, and versions
    • IBM System Storage DS8000™ (DS8100, DS8300, or DS8700) with DS8000 Release Version 3.1.1, and later 3.1.x levels, releases, and versions, as supported by the IBM System Storage VSS Hardware provider 4.0, and later 4.0.x levels, releases, and versions

Rate this page:

(0 users)Average rating

Document information


More support for:

Tivoli Storage Manager for Databases
Data Protection for MS SQL

Software version:

5.5.6

Operating system(s):

Windows

Reference #:

1610263

Modified date:

2012-09-05

Translate my page

Machine Translation

Content navigation