Troubleshooting
Problem
After installing the 32-bit version of IBM Informix Client SDK or IBM Informix Connect, the IBM Informix ODBC driver does not show up when configuring a data source via the Microsoft ODBC Administrator.
Symptom
The list of available ODBC drivers within Microsoft's ODBC Administrator does not include the IBM Informix ODBC driver.
Cause
The cause of the problem is due to running the 64-bit Microsoft ODBC Administrator. The default 64-bit ODBC Administrator on a 64-bit Windows machine (Windows 7, Windows 2003 or Windows 2008) is c:\windows\system32\odbcad32.exe. This is a 64-bit version of the ODBC Administrator and hence, the 32-bit IBM Informix ODBC driver will not be displayed in the list of available drivers. In instead, you run the 32-bit Microsoft ODBC Administrator (c:\windows\sysWOW64\odbcad32.exe), the proper 32-bit driver will be displayed in the list of available drivers.
Environment
Windows 7, Windows 2003 and Windows 2008
Resolving The Problem
Configure the 32-bit ODBC driver by using the 32-bit Microsoft ODBC Administrator (odbcad32.exe) that is located in c:\windows\sysWOW64.
Was this topic helpful?
Document Information
Modified date:
20 January 2022
UID
swg21609502