Limited Spooled File Capability in RD Power

News


Abstract

Limited capability for viewing Spooled Files on an IBM i was added to the RD Power product.

Content

Some new ability to view Spooled Files was added in RD Power 8.0.

Updated for RD Power 8.5:

    See *SHOWSPLF - Show Spooled File output from Commands and 'Delete' action added for selected spooled files below:


Disclaimer:
    This work was done unofficially, by one of the developers as an interest project in their free time.

    It is included in the shipped release, but was never officially designed, reviewed, or tested.
    There is no mention of it in any of the documentation or help.

    As such, it is also not officially supported; so please don't submit PMRs or APARs on it.


The Spooled File support in version 8.0 of the product:

In the Remote System Explorer view, under an IBM i Connection, there is a new node for a Spooled File Subsystem..
It comes with a default filter, but you can also add your own spooled file filters.

(A default filter may not be supplied. If not, right click on the Spooled File subsystem node to add a filter.)

The filters can be expanded to show as nodes in the tree, or one can right click on a filter to open the context menu and select the 'Show Spooled File Table' action to see the list of spooled files shown in a separate table view of spooled files.




The Spooled File Table view:




Selecting a spooled file, you can have its contents shown in a browser view

Known defect: There seems to be a problem that the spooled file text view is not populated the first time it is launched in a workbench session for a connection. Close the spooled file browser view and re-show the spooled file again.






Recommendation: For a better appearance than above, change the default font used in the spooled file text viewer to a non-proportional font. Right click in the text view window for the context menu, and select the 'Set Font' action. (Suggested font: Lucida Console, size 8) This only needs to be done once for the workspace.





There are two tabs in the browser view that you can toggle between; which show the contents in two separate formats. The first is a text format. The content is retrieved as a print device stream, and all but the text data is stripped out for viewing.

Known defect in RD Power 8.0: It doesn't do a perfect job of filtering out all the printer formatting codes. Notably, there is some garbage text shown on the first line. This was fixed in RD Power 8.5.


The second page tab is for an image format. The content is retrieved one page image at a time as a graphic image and shown.
You can scroll the view image around within the one page.
Pressing the page down/up keys should go to the next page, after requesting and getting it from the IBM i.

Known defect: There are 2 vertical scroll bars; the inner for within the page, the outer for selecting pages. But trying it there doesn't appear to be a slider in the outer scroll bar.


New in RD Power 8.5: *SHOWSPLF - Show Spooled File output from Commands:

There is now a way to have the spooled file output resulting from a command launched from the RD Power client automatically displayed in the client workbench when the command completes. This can be applied to the RSE-provided compile commands, or to custom user defined commands.

Note: This only works for commands run in 'Normal' mode, not for commands run as Batch or Interactive.

Some of the interactive DSP* or WRK* commands which previously were inaccessible from the client can now also be used if they have an OUTPUT(*PRINT) option to send their results to a spooled file.

To use this feature, specify the keyword *SHOWSPLF within a CL comment at the end of the command string for a CL command which is a compile command, or a defined user command, or specified in the Commands Log view or Object Table View. When the command finishes, the client retrieves the latest spooled file for the connection userid and displays it in a browser view.

Note:
1. The client retrieves the newest spooled file for the user, which may not be the spooled output file from the command if multiple spooled output files were produced or some other job or process has created a spooled file for the user.
2. This applies only to commands launched as Normal. Not for Batch or Interactive.
3. The command must support outputting results to a spooled file, bypassing output to a display file device. (On system commands this is commonly an OUTPUT(*PRINT) option.)

Examples:

1. To Modify a Compile Command: Select an RPGLE source member in the Remote System Explorer tree view, right click for the pop-up context menu, select Compile -> Work with Compile Commands. Select the CRTRPGMOD command and Edit it. Add /* *SHOWSPLF */ to the end of the command string, then finish and save it.

ie. CRTRPGMOD MODULE(&O/&N) SRCFILE(&L/&F) SRCMBR(&N) REPLACE(&R) OPTION(*EVENTF) DBGVIEW(*SOURCE) /* *showsplf */


2. To add a user defined action: For example we can define a Display Savefile Contents action.
Right click on an object in the Objects subsystem under an IBM i Connection in the RSE tree view to open the popup context menu, select User Actions -> Work with User Actions. Add an object level command for SAVEFILE object types with the command string : DSPSAVF FILE(&L/&N) OUTPUT(*PRINT) /* *SHOWSPLF */

One can then select a SAVF object in the RSE tree view, right click for the context menu, select User Actions -> DSPSAVF and the spooled file showing the savefilel contents will open in the browse view.





3. Define commands in the Commands Subsystem. (These can be run without first selecting a remote object in the tree.)
This can be particularly useful for system status commands.

Right click on the Commands subsytem under an IBM i connection, select New -> Command Set and specify a command string
ie. DSPSYSSTS OUTPUT(*PRINT) /* *SHOWSPLF */
or, wrkactjob output(*print) /* *showsplf */


New in RD Power 8.5: 'Delete' action added for selected spooled files:

A delete action is now available as one of the context menu actions for a spooled file listed in the Remote System Explorer view or in the Spooled File Table view..

Known defect: When deleting a spooled file using this action from the expanded spooled file filter in the Remote System Explorer tree view, the selected spooled file is not automatically removed from the tree view. The filter must be manually refreshed to show the change.

The action in the Spooled File Table view:


Rate this page:

(0 users)Average rating

Document information


More support for:

Rational Developer for Power Systems Software
RPG and COBOL Development Tools for i

Software version:

8.0, 8.0.3, 8.5

Operating system(s):

Linux, Windows

Software edition:

All Editions

Reference #:

1608550

Modified date:

2012-08-21

Translate my page

Machine Translation

Content navigation