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Universal Agent fails to start with KCICF5100E


Technote (troubleshooting)


Problem(Abstract)

IBM Tivoli Monitoring Universal Agent terminates / is off-line.

Symptom

Universal Agent will not start, reporting KCICF5100E message

In RAS1 log for UM component:
kumdsock.cpp,1180,"ipcSock::allocateDCHport") Error: Could not open TCP/UDP sockets bound to Universal Agent DCH port 1919 for IP address 123.456.7.890
kumdsock.cpp,1181,"ipcSock::allocateDCHport") Verify that Universal Agent has been configured with the correct local IP address. Exiting...

Cause

Invalid entry in DNS server or Windows system "hosts" file.

Environment

Universal Agent on Windows platforms.

Diagnosing the problem

In KUMENV:

CTIRA_HOSTNAME=LABSYSTEM1

In the UM RAS1 log:
kdebprc.c,989,"interface_discovery") IPV4 interface(s): 'LABSYSTEM1', mask=0x00:0x50 123.456.7.890: source=hostname:0, seq=0, mask=0x02
xxx.xxx.xxx.xxx: source=winsock:0, seq=0, mask=0x01
xxx.xxx.xxx.xxx: source=winsock:1, seq=0, mask=0x01
127.0.0.1: source=loopback, seq=0, mask=0x10, loopback

kum0sock.c,214,"KUM0_OpenLocalSocket") *** bind failed for local TCP address LABSYSTEM1 addrlen 16 socket 3684, port=0, errno=10049

kum0sock.c,214,"KUM0_OpenLocalSocket") *** bind failed for local UDP address LABSYSTEM1 addrlen 16 socket 3712, port=0, errno=10049
kumdsock.cpp,2123,"ipcSock::IPCClient") Error: _sockUDP[-1] errno=0
kumdipc.cpp,147,"DCHipc::startup") Error: IPCClient failed

kumdsock.cpp,218,"ipcSock::ipcSock") Error: startup failed. _sockError=1
kumdsock.cpp,223,"ipcSock::ipcSock") Error: _sockError=1
kumdsock.cpp,1510,"ipcSock::openDCHsocket") *** bind failed for DCH UDP address LABSYSTEM1 addrlen 16 socket 3760 port=1919 errno=10049
kumdsock.cpp,1510,"ipcSock::openDCHsocket") *** bind failed for DCH TCP address LABSYSTEM1 addrlen 16 socket 3756 port=1919 errno=10049
kumdsock.cpp,1180,"ipcSock::allocateDCHport") Error: Could not open TCP/UDP sockets bound to Universal Agent DCH port 1919 for IP address 123.456.7.890
kumdsock.cpp,1181,"ipcSock::allocateDCHport") Verify that Universal Agent has been configured with the correct local IP address. Exiting...

Confirm if the IP address specified on the allocateDCHport tracepoint maps to a network adapter on the Universal Agent system. In the above, 123.456.7.890 was listed in the interface_discovery, but it was not the address for any network adapter on the system seen in the ipconfig.info file gathered with "pdcollect" utility.

If the IP address does not map to a network adapter on the system, check the contents of the Windows "hosts" file or DNS server for entries that would match the CTIRA_HOSTNAME and IP address output in above trace messages.

The Windows "hosts" file is located in %SystemRoot%\system32\drivers\etc\ directory where the %SystemRoot% in the beginning is a variable that is set to the Windows install directory.
Most Windows users have installed the operating system on C:\windows which would mean that the hosts file would be:
c:\windows\system32\drivers\etc\hosts

Resolving the problem

If the problem is an invalid / incorrect IP address being used for the system where the Universal Agent is installed, correct "hosts" entries or values on the DNS server that map the incorrect IP address to the hostname being used.


Very similar errors can be seen if there is a problem allocating port 1919, even if the IP address is valid.
If the IP address being used appears correct, confirm if some other application / process is using port 1919 which will prevent the Universal Agent from binding to it and result in same failure with the DCH port.

Documentation to gather to confirm if some other application is using 1919:
Commands issued from DOS prompt on Universal Agent system:
"nslookup LABSYSTEM1"
"ping LABSYSTEM1"
"netstat -a"
"netstat -b"

Use the "netsat -a" to verify if port 1919 is already in use, if it is, confirm what application / process is using port 1919 in the "netstat -b" output.

If it is not possible to configure the other application / process to use a port other than 1919, configure the Universal Agent to set a different value for the DCH port to an available port:

KUMA_DCH_PORT=####

Where #### is an availalbe port.

Additional details for setting an alternate DCH port can be found in Technote 1316066.


Related information

DCF Technote 1316066

Historical Number

74436
228
631

Product Alias/Synonym

5724K1000

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Document information

Tivoli Universal Agent


Software version:
Version Independent


Operating system(s):
Windows, Windows 2000, Windows 2003 server, Windows 2008 server, Windows 2012 server, Windows 64bit, Windows 7, Windows Vista, Windows XP


Software edition:
All Editions, Edition Independent


Reference #:
1608361


Modified date:
2012-12-28

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