Installation of IBM SPSS Amos 21 or 22 requires Microsoft .NET Framework version 4.0

Technote (troubleshooting)


Problem(Abstract)

Installation of the IBM SPSS Amos 21 application on a Windows system may bring up the following error message:
"The Microsoft.Net Framework Version 4.0 was not found on your machine. This is required for the Amos installation to continue. Please install the Microsoft.NET framework first."

This version of .NET Framework was not required in previous releases of IBM SPSS Amos.

Cause

With the upgrade to IBM SPSS Amos 21 or 22, Microsoft .NET Framework Version 4.0 is now a required prerequisite.

Please note that you must install the full setup of Microsoft .NET framework 4.0 (dotNetFx40_Full_setup.exe).
On Windows 7 operating systems the preinstalled Microsoft .NET Framework 4 Client Profile (version 4.0.30319) is NOT the full, extended setup of the framework and not sufficient for the AMOS installation. For AMOS you need the full setup of .NET Framework 4 Extended (version 4.0.30319.
See below for download link.


Resolving the problem

Please proceed in downloading the .NET Framework version 4.0 from the Microsoft Website found here.

Note that this may require a restart of your computer.

After installation of .NET v4.0 full setup, please re-install IBM SPSS Amos 21.

Rate this page:

(0 users)Average rating

Document information


More support for:

SPSS Amos

Software version:

21.0

Operating system(s):

Windows

Reference #:

1608298

Modified date:

2013-08-26

Translate my page

Machine Translation

Content navigation