Delete subscriptions before upgrading the WebSphere Message Broker Monitoring agent from 7.0.1 FP1 or earlier

Technote (FAQ)


Question

When upgrading the WebSphere Message Broker Monitoring agent from 7.0.1 FP1 or earlier to 7.0.1 FP2 or later, what to do with subscriptions with the persistentBrokerData value being YES?

Answer

If you want to upgrade the WebSphere Message Broker Monitoring agent from 7.0.1 FP1 or earlier to 7.0.1 FP2 or later, before you upgrade the agent, check the value of the defaultPersistentBrokerData parameter (or the persistentBrokerData value of the given broker) in the agent configuration file. The defaultPersistentBrokerData parameter controls the persistent data store of all brokers running on the same system. The persistentBrokerData parameter controls the persistent data store of the broker specified in the MonitorBroker tag. And please refer to the user guide for the configuration details.
If the defaultPersistentBrokerData (or persistentBrokerData) value is Yes, the following tasks are required by the brokers of version 7 or later on distributed systems and brokers of all versions on z/OS systems:

1. Delete the subscription $SYS/Broker/<broker_label>/# manually.
- V6.1 brokers on z/OS systems: Use the Message Broker Toolkit
- V7 or later brokers: Use the WebSphere MQ Explorer or WebSphere MQ command DELETE SUB.

2. Delete the reply queue that is used by the WebSphere Message Broker monitoring agent. The name of the reply queue is specified by the defaultReplyQueueName parameter (or the replyQueueName parameter for the given broker).

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

Tivoli Composite Application Manager for Applications
ITCAM agents for Websphere Messaging

Software version:

7.0.1

Operating system(s):

AIX, HP-UX, Linux, Solaris, Windows, z/OS

Reference #:

1608092

Modified date:

2014-07-15

Translate my page

Machine Translation

Content navigation