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The server returned an unrecognizable metadata response.

Troubleshooting


Problem

When opening reports against any package, get the following error in a popup window. The server returned an unrecognizable metadata response.

Symptom

Unable to view the metadata tree within IBM Cognos Report Studio.

On Screen error:-

The server returned an unrecognizable metadata response.

Seen the following error in the cogserver.log:
DPR-ERR-2088 The requested Server Group 'fdn' does exist

Cause

Routing rule was defined to a dispatcher that was removed from the environment.

Environment

Windows, Unix

Resolving The Problem

1) From the IBM Cognos portal, go to the IBM Cognos Administration page from Launch->IBM Cognos Administration menu

2) Click the Configuration Tab

3) Click the Dispatchers and Service link

4) Click the "Specify Routing Rules" button in the upper right of the page.

A message will be displayed that a resource associated with a routing rule no longer exists. At that point,the routing rule will be removed. Exit the routing rule page. The issue will be resolved after this action.

[{"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Report Studio","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"10.2.2;10.2.1;10.2","Edition":"All Editions","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21607926